Appium Able to find Element and Click on it(Response is 200).But the click is not reflected on the UI.(Android)

The element to be clicked is present in the XML.But when it is to be clicked not visible on the UI. It is visble on scrolling to the element.

I have tried implementing the scrollToExact method and then try and click the element but that has failed.
Also have used Swipe to element but to no gain.

Faced the Issue on Android,the same Works fine on iOS App.

Any Help? Looks like a bug to me,May be on the uiAutomator side or Appium itself.

Mayuresh, wondering if yu were able to get around with the issue. Thanks

Manjiri_Sakdeo unfortunately couldn’t do much about it.
But you could use Action Builder or Appium tap method instead.

Also as mine was a hybrid app, i could use the Webview and got the element clicked.But couldn’t do anything with the Native version.

I had posted the issue on github,So if you could send ur appium logs on this post,I could post it there and probably get it solved.