Appium doesn't launch Safari on real device (iPhone X with iOS 13.3)

Hi all :slight_smile:

I am struggling with launching mobile Safari on real device. I managed to make Appium install WDA runner on my iPhone X. The last server response is:

[debug] [WD Proxy] Proxying [POST /session] to [POST http://localhost:8100/session] with body: {“capabilities”:{“firstMatch”:[{“bundleId”:“com.apple.mobilesafari”,“arguments”:[],“environment”:{},“eventloopIdleDelaySec”:0,“shouldWaitForQuiescence”:true,“shouldUseTestManagerForVisibilityDetection”:false,“maxTypingFrequency”:60,“shouldUseSingletonTestManager”:true}],“alwaysMatch”:{}}}

And after that nothing happens, server kind of freezes on this state. If I manually open Safari, appium opens Appium.io page, but does not open a web app which I need to test.

I will appreciate your help in this case. On Simulator I can run my tests with no issues…Maybe some capabilities are missing for Safari on a real device? My current capabilities are:

public static AppiumDriver<IOSElement> driver;

@BeforeClass
public static void setUpAppium() throws MalformedURLException {

URL url = new URL(“http://127.0.0.1:4723/wd/hub”);
DesiredCapabilities capabilities = new DesiredCapabilities();
capabilities.setCapability(MobileCapabilityType.PLATFORM_NAME, “iOS”);
capabilities.setCapability(MobileCapabilityType.PLATFORM_VERSION, “13.3”);
capabilities.setCapability(MobileCapabilityType.DEVICE_NAME, “iPhone X”);
capabilities.setCapability(MobileCapabilityType.BROWSER_NAME, “Safari”);
capabilities.setCapability(“automationName”, “XCUITest”);
capabilities.setCapability(“udid”, “id of my device”);
capabilities.setCapability(“useNewWDA”, true);

    driver = new AppiumDriver<IOSElement>(url, capabilities);

Thanks in advance :pray: