Appium failed on real ios8 device

I run the test on real ios 6 or 7 device. It works fine. On real ios 8 device, it starts up successfully. On the former pages of my app, it appears no problem. However, when it goes to a normal page, it fails! So strange! I’ve tried different ios8 devices for many times. All goes to the same result. Here’s the key log:

info: [debug] Responding to client with error: {"status":13,"value":{"message":"An unknown server-side error occurred while processing the command. (Original error: connect ECONNREFUSED)","code":"ECONNREFUSED","errno":"ECONNREFUSED","syscall":"connect","origValue":"connect ECONNREFUSED"},"sessionId":"5ef8dd2e-1502-4d9f-b504-a4e0f110585f"}
info: <-- GET /wd/hub/session/5ef8dd2e-1502-4d9f-b504-a4e0f110585f/contexts 500 8.240 ms - 293 

error: [REMOTE] Could not connect to WebKitRemoteDebugger server

Anyone could help me out of this?
I’m using appium1.3.4, iphone6 8.1.2, macos 10.10

In addition, I cannot do any operations in the failed page. And the appium seems to get nothing from the page.

Any ideas appreciated!