Appium - iOS issue - SDK upgrdation 11.2


#1

We have been using Native app,we couldn’t able to identify only certain elements in iOS after SDK upgradation , For example after selecting the date in date picker, other UI fields are not accessible and could not able to see anything in object hierarchy. The same objects got identified before selecting the value in DOB field. Tried with below combinations
Xcode Appium iOS Version
9.1 1.8.1 11.3
9.2 1.8.1 10.3.3
9.3 1.8.1 11.3
9.3 1.7.2 11.3
9.3 1.8.1 10.3.3
SDK Upgradation version - 11.2, iOS version 10.3.3/11.3. Could you please help us out in this issue?


#2

Hi @keerthin
actually that is not an issue from appium side, it’s an issue of UIAccessibility framework from iOS. upgrade iOS to 11.4 and try to select values from pickerwheel, i hope it will work.


#3

Hi Tany_S,

Thanks for the reply, we tried even in iOS version 11.4 with Xcode 9.4.1 and appium 1.8.1 but still facing the same issue. Could you please help us out? Or please mention the Xcode and appium combination to try it out ?


#4

can u share the log.


#5


Hi Tany_S,
Attached the appium logs(higlighted logs are generated after selecting datepicker in the application)


#6

@keerthin the logs you shared, in that i didn’t find any operation like selecting date picker. please investigate more in logs and also refer xcode crash logs if your application is getting crashed while selecting date picker.

and i am trying with Xcode - 9.4.1
iOS - 11.4
Appium Desktop - 1.5.0


#7

Thanks Tany_S, it worked