Appium is opening and closing application on emulator until server stops. IOS

[debug] [WebDriverAgent] WebDriverAgent information:

[debug] [WebDriverAgent] {

[debug] [WebDriverAgent] “message”: “WebDriverAgent is ready to accept commands”,

[debug] [WebDriverAgent] “state”: “success”,

[debug] [WebDriverAgent] “os”: {

[debug] [WebDriverAgent] “testmanagerdVersion”: 28,

[debug] [WebDriverAgent] “name”: “iOS”,

[debug] [WebDriverAgent] “sdkVersion”: “14.2”,

[debug] [WebDriverAgent] “version”: “14.3”

[debug] [WebDriverAgent] },

[debug] [WebDriverAgent] “ios”: {

[debug] [WebDriverAgent] “simulatorVersion”: “14.3”,

[debug] [WebDriverAgent] “ip”: “192.168.0.100”

[debug] [WebDriverAgent] },

[debug] [WebDriverAgent] “ready”: true,

[debug] [WebDriverAgent] “build”: {

[debug] [WebDriverAgent] “upgradedAt”: “1608759180733”,

[debug] [WebDriverAgent] “time”: “Dec 24 2020 11:45:21”,

[debug] [WebDriverAgent] “productBundleIdentifier”: “com.facebook.WebDriverAgentRunner”

[debug] [WebDriverAgent] }

[debug] [WebDriverAgent] }

[debug] [WebDriverAgent] WebDriverAgent successfully started after 11476ms

[debug] [BaseDriver] Event ‘wdaSessionAttempted’ logged at 1608796241172 (11:50:41 GMT+0400 (Georgia Standard Time))

[debug] [XCUITest] Sending createSession command to WDA

[debug] [WD Proxy] Matched ‘/session’ to command name ‘createSession’

[debug] [WD Proxy] Proxying [POST /session] to [POST http://127.0.0.1:8100/session] with body: {“capabilities”:{“firstMatch”:[{“bundleId”:“com.stage.Mobile”,“arguments”:[],“environment”:{},“eventloopIdleDelaySec”:0,“shouldWaitForQuiescence”:true,“shouldUseTestManagerForVisibilityDetection”:false,“maxTypingFrequency”:60,“shouldUseSingletonTestManager”:true}],“alwaysMatch”:{}}}

[WD Proxy] Got response with status 400: {“value”:{“error”:“invalid element state”,“message”:“The application under test with bundle id ‘com.stage.Mobile’ is not running, possibly crashed”,“traceback”:"(\n\t0 CoreFoundation 0x00007fff20420af6 __exceptionPreprocess + 242\n\t1 libobjc.A.dylib 0x00007fff20177e78 objc_exception_throw + 48\n\t2 CoreFoundation 0x00007fff20420797 -[NSException init] + 0\n\t3 WebDriverAgentLib 0x000000010327163b -[FBSession activeApplication] + 667\n\t4 WebDriverAgentLib 0x000000010327e9ba +[FBSessionCommands currentCapabilities] + 90\n\t5 WebDriverAgentLib 0x000000010327e889 +[FBSessionCommands sessionInformation] + 233\n\t6 WebDriverAgentLib 0x000000010327b776 +[FBSessionCommands handleCreateSession:] + 2918\n\t7 WebDriverAgentLib 0x000000010324bfb6 -[FBRoute_TargetAction mountRequest:intoResponse:] + 182\n\t8 WebDriverAgentLib 0x…

[debug] [W3C] Matched W3C error code ‘invalid element state’ to InvalidElementStateError

[debug] [XCUITest] Failed to create WDA session (The application under test with bundle id ‘com.stage.Mobile’ is not running, possibly crashed). Retrying…

P.S--------------- I can open application manually on emulator, with drag and drop. but with appium server is opening and closing application until the server stops .

I have got an .app file from dev team.