Appium Session Time Out / UI Automator Died

I am using appium for android native app automation.

It works fine but sometimes suddenly it throws the following error and
other testcases get skipped or fail. What can be cause and the
solution. I run the script by jenkins. Alternate build gets fail in
between. Is this appium session problem or extent reports problem.
Error Trace:

Exception While Capturing ScreenShot

Command duration or timeout: 10 milliseconds

Build info: version: ‘2.42.2’, revision: ‘6a6995d31c7c56c340d6f45a76976d43506cd6cc’, time: ‘2014-06-03 10:52:47’

System info: host: ‘LON-HOST2’, ip: ‘192.168.137.3’, os.name: ‘Windows
Server 2012 R2’, os.arch: ‘amd64’, os.version: ‘6.3’, java.version:
‘1.7.0_79’

Session ID: ef3a28be-e341-4655-bcb5-ff3b878a5c73

Driver info: io.appium.java_client.android.AndroidDriver

Capabilities [{platform=LINUX,
app=C:\Automation_Projects\WebDriver_TestNg_Maven_SRMS\App_Prod\Banco
Popular.apk, javascriptEnabled=true, browserName=Android,
networkConnectionEnabled=true, Automation=Appium 1.4.0.0,
desired={newCommandTimeout=90000,
app=C:\Automation_Projects\WebDriver_TestNg_Maven_SRMS\App_Prod\Banco
Popular.apk, platformVersion=4.4.2, platformName=Android,
deviceName=emulator-5554, Automation=Appium 1.4.0.0},
locationContextEnabled=false, newCommandTimeout=90000,
platformVersion=4.4.2, databaseEnabled=false, deviceName=emulator-5554,
platformName=Android, webStorageEnabled=false, warnings={},
takesScreenshot=true}]

Error MessageUiAutomator died while responding to command, please check appium logs! (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 297 milliseconds
Build info: version: ‘2.53.0’, revision: ‘35ae25b1534ae328c771e0856c93e187490ca824’, time: ‘2016-03-15 10:43:46’
System info: host: ‘LON-HOST2’, ip: ‘192.168.137.3’, os.name: ‘Windows Server 2012 R2’, os.arch: ‘amd64’, os.version: ‘6.3’, java.version: ‘1.7.0_79’
Session ID: a9c7b53a-b0e9-4d69-a70d-d43c61cc7efc
Driver info: io.appium.java_client.android.AndroidDriver
Capabilities [{platform=LINUX, app=C:\Automation_Projects\WebDriver_TestNg_Maven_SRMS\App_Prod\BancoPopular.apk, javascriptEnabled=true, browserName=Android, networkConnectionEnabled=true, Automation=Appium 1.4.0.0, desired={newCommandTimeout=150000, app=C:\Automation_Projects\WebDriver_TestNg_Maven_SRMS\App_Prod\BancoPopular.apk, platformVersion=4.4.2, platformName=Android, deviceName=emulator-5554, Automation=Appium 1.4.0.0}, locationContextEnabled=false, newCommandTimeout=150000, platformVersion=4.4.2, databaseEnabled=false, deviceName=emulator-5554, platformName=Android, webStorageEnabled=false, warnings={}, takesScreenshot=true}]

Please anyone who can help me for the above error…