Appium support Android N (7.0)


#1

Hi,

Does appium support Android N (7.0)? When i try to run test suite on Android N getting below errors:

info: Welcome to Appium v1.4.16 (REV ae6877eff263066b26328d457bd285c0cc62430d)
info: Appium REST http interface listener started on 127.0.0.1:4723
info: [debug] Non-default server args: {“address”:“127.0.0.1”,“noReset”:true,“androidPackage”:“com.mobitv.client.tmobiletvhd”,“androidActivity”:“com.mobitv.client.connect.mobile.StartupActivity”}
info: Console LogLevel: debug
info: --> POST /wd/hub/session {“desiredCapabilities”:{“browserName”:"",“app-package”:null,“app-activity”:“com.mobitv.client.connect.mobile.StartupActivity”,“platformName”:“Android”,“device”:“Android”,“version”:“4.4.2”,“deviceName”:“MobiTV”,“appAPK”:“D:\mobi-client-qa-nma-testng\apk\com.mobitv.client.tmobiletvhd-7.7.20-debug.apk”}}
info: Client User-Agent string: Apache-HttpClient/4.4.1 (Java/1.8.0_91)
info: [debug] The following desired capabilities were provided, but not recognized by appium. They will be passed on to any other services running on this server. : app-package, app-activity, device, version, appAPK
info: [debug] Didn’t get app but did get Android package, will attempt to launch it on the device
info: [debug] Creating new appium session d6e52ad3-1ea2-4c54-8942-c45e0927bdde
info: Starting android appium
info: [debug] Getting Java version
info: Java version is: 1.8.0_91
info: [debug] Checking whether adb is present
info: [debug] Using adb from C:\adt\platform-tools\adb.exe
warn: No app capability, can’t parse package/activity
info: [debug] Using fast reset? false
info: [debug] Preparing device for session
info: [debug] Not checking whether app is present since we are assuming it’s already on the device
info: Retrieving device
info: [debug] Trying to find a connected android device
info: [debug] Getting connected devices…
info: [debug] executing cmd: C:\adt\platform-tools\adb.exe devices
info: [debug] 1 device(s) connected
info: Found device LGH9185642f30f
info: [debug] Setting device id to LGH9185642f30f
info: [debug] Waiting for device to be ready and to respond to shell commands (timeout = 5)
info: [debug] executing cmd: C:\adt\platform-tools\adb.exe -s LGH9185642f30f wait-for-device
info: [debug] executing cmd: C:\adt\platform-tools\adb.exe -s LGH9185642f30f shell “echo ‘ready’”
info: [debug] Starting logcat capture
info: [debug] Getting device API level
info: [debug] executing cmd: C:\adt\platform-tools\adb.exe -s LGH9185642f30f shell “getprop ro.build.version.sdk”
info: [debug] Device is at API Level 24
info: Device API level is: 24
info: [debug] Extracting strings for language: default
info: [debug] Apk doesn’t exist locally
info: [debug] Could not get strings, but it looks like we had an old strings file anyway, so ignoring
info: [debug] executing cmd: C:\adt\platform-tools\adb.exe -s LGH9185642f30f shell “rm -rf /data/local/tmp/strings.json”
info: [debug] Not uninstalling app since server not started with --full-reset
info: [debug] Skipping install since we launched with a package instead of an app path
info: [debug] Forwarding system:4724 to device:4724
info: [debug] executing cmd: C:\adt\platform-tools\adb.exe -s LGH9185642f30f forward tcp:4724 tcp:4724
info: [debug] Pushing appium bootstrap to device…
info: [debug] executing cmd: C:\adt\platform-tools\adb.exe -s LGH9185642f30f push “C:\Appium\node_modules\appium\build\android_bootstrap\AppiumBootstrap.jar” /data/local/tmp/
info: [debug] Pushing settings apk to device…
info: [debug] executing cmd: C:\adt\platform-tools\adb.exe -s LGH9185642f30f install “C:\Appium\node_modules\appium\build\settings_apk\settings_apk-debug.apk”
info: [debug] Pushing unlock helper app to device…
info: [debug] executing cmd: C:\adt\platform-tools\adb.exe -s LGH9185642f30f install “C:\Appium\node_modules\appium\build\unlock_apk\unlock_apk-debug.apk”
info: Starting App
info: [debug] Attempting to kill all ‘uiautomator’ processes
info: [debug] Getting all processes with ‘uiautomator’
info: [debug] executing cmd: C:\adt\platform-tools\adb.exe -s LGH9185642f30f shell “ps ‘uiautomator’”
info: [debug] Stopping logcat capture
info: [debug] Logcat terminated with code null, signal SIGTERM
info: [debug] Sent shutdown command, waiting for UiAutomator to stop…
warn: UiAutomator did not shut down fast enough, calling it gone
info: [debug] Cleaning up android objects
info: [debug] Cleaning up appium session
error: Failed to start an Appium session, err was: Error: Could not extract PIDs from ps output. PIDS: [], Procs: [“bad pid ‘uiautomator’”]
info: [debug] Error: Could not extract PIDs from ps output. PIDS: [], Procs: [“bad pid ‘uiautomator’”]
at C:\Appium\node_modules\appium\node_modules\appium-adb\lib\adb.js:1059:17
at [object Object]. (C:\Appium\node_modules\appium\node_modules\appium-adb\lib\adb.js:180:9)
at ChildProcess.exithandler (child_process.js:742:7)
at ChildProcess.emit (events.js:110:17)
at maybeClose (child_process.js:1016:16)
at Process.ChildProcess._handle.onexit (child_process.js:1088:5)
info: [debug] Responding to client with error: {“status”:33,“value”:{“message”:“A new session could not be created. (Original error: Could not extract PIDs from ps output. PIDS: [], Procs: [“bad pid ‘uiautomator’”])”,“origValue”:“Could not extract PIDs from ps output. PIDS: [], Procs: [“bad pid ‘uiautomator’”]”},“sessionId”:null}
info: <-- POST /wd/hub/session 500 10097.101 ms - 288


#2

A search for “Android N” will turn up previous discussions on the topic. This one might address your current problems: Support version Android N


#3

has your issue resolved i am also getting same error.


#4

has your issue resolved i am also getting same error.


#5

has your issue resolved i am also getting same error.


#6

has your issue resolved i am also getting same error.
has your issue resolved i am also getting same error.


#7

Have you tried the solutions listed on that page? If they didn’t work, what are you seeing in the server log?