Appium version is missing or invalid 1.3.4

Why am I getting an “invalid” version for the 1.3.4 while trying to run an automation on Saucelabs?
It was working fine yesterday.
Also, if I try the same locally it works ok, so the issues it’s onyl on remote runs.

It looks like if you change to 1.4.0 it works, but: Why isn’t working for 1.3.4?

@jonahss have you guys seems this before? any ideas?

You may use https://docs.saucelabs.com/reference/platforms-configurator to check the available platforms.