Cannot access appium settings when using Espresso as an Automation Name

I have set the automation name to “Espresso” in my capabilities. whenever i call
Driver.SetSetting(“driver”,“compose”) or Driver.SetSetting(“imageMatchThreshold”, “0.7”)
Original error: No such route: /session/e6c57496-b6de-475f-9ba3-8277fac13c3f/appium/settings
If i set the automation name to UiAutomator 2. It works fine says

Jetpack Compose is Android’s modern toolkit for building native UI. Espresso driver supports basic interactions with Compose-based applications since version 1.46.0

What is your driver version?

Hi, I am using appium 2.0. The version of espresso driver that i am using is 2.15.1.
That’s fine for the compose.
My Automation Name in driver’s capability is set to Espresso, I tried to execute this command in c#
Driver.SetSetting(“imageMatchThreshold”, “0.7”) and didn’t work. It says i cannot access appium settings
Original error: No such route: /session/e6c57496-b6de-475f-9ba3-8277fac13c3f/appium/settings.
any help on that?
Otherwise i won’t be able to find elements by image in c#

Please provide the full server log

here it is.
appium-server-logs.txt (28.1 KB)

[info] e[35m[Appium]e[39m Appium v1.22.3 creating new EspressoDriver (v1.45.3) session

Are you sure this is the right log?

The first one was using Appium GUI for this reason you had Appium v1.22.3
Below is the file attached for Appium 2.0.0.beta56 and espresso driver 2.15.12023-03-02-21-22-26-668___7af6cf11-078f-4691-8370-509c8363b0b9.log (10.4 KB)

The above file still does not look like a valid server log

here it is, checked the appium version inside the file
appiumServerLogs.txt (31.9 KB)

2023-03-02 20:34:05:769 [[email protected] (65f26bad)] Matched ‘/appium/settings’ to command name ‘updateSettings’
2023-03-02 20:34:05:770 [[email protected] (65f26bad)] Proxying [POST /appium/settings] to [POST] with body: {“settings”:{“imageMatchThreshold”:“0.7”}}
2023-03-02 20:34:05:822 [[email protected] (65f26bad)] Got response with status 500: {“id”:“eedb4247-49ab-4085-9d08-f968f3017619”,“sessionId”:null,“value”:{“error”:“unknown error”,“message”:“No such route: /session/14faa01a-b87f-4f93-8bd7-dd70950f3d82/appium/settings”,“stacktrace”:“io.appium.espressoserver.lib.handlers.exceptions.AppiumException: No such route: /session/14faa01a-b87f-4f93-8bd7-dd70950f3d82/appium/settings\n\tat io.appium.espressoserver.lib.http.Router.route(Router.kt:188)\n\tat io.appium.espressoserver.lib.http.Server.serve(Server.kt:51)\n\tat fi.iki.elonen.NanoHTTPD$HTTPSession.execute(\n\tat fi.iki.elonen.NanoHTTPD$\n\tat\n”}}

It looks like you might have some cached espresso server running from an older Appium version. Make sure the correct one is used by setting forceEspressoRebuild capability to true

Got a new error saying "Could not find matching setting. Known setting names are: [driver]"2023-03-02-23-30-47-083___7af6cf11-078f-4691-8370-509c8363b0b9.log (10.5 KB)

It worked i changed it from Driver.SetSetting(“imageMatchThreshold”, “0.7”) to Driver.Settings[“imageMatchThreshold”]= “0.7”;

I have another question:
If we are implementing an Android App using Xamarin, should I use Espresso driver or UiAutomator 2?