Cannot install Appium 1.6.0-beta3 if authorize-ios and appium-doctor are installed

  • Appium1.6.0-beta3
  • Javascript
  • macOS Sierra

I have to uninstall authorize-ios and appium-doctor if I want to install appium1.6.0-beta3 locally to my project and then reinstall them afterwards.

10645 error Darwin 16.0.0
10646 error argv "/Users/tom/.nvm/versions/node/v4.4.5/bin/node" "/Users/tom/.nvm/versions/node/v4.4.5/bin/npm" "install" "[email protected]"
10647 error node v4.4.5
10648 error npm  v3.10.5
10649 error path /Users/tom/pathToApp/node_modules/appium/node_modules/.bin/authorize-ios
10650 error code ENOENT
10651 error errno -2
10652 error syscall chmod
10653 error enoent ENOENT: no such file or directory, chmod '/Users/tom/pathToApp/node_modules/appium/node_modules/.bin/authorize-ios'
10654 error enoent ENOENT: no such file or directory, chmod '/Users/tom/pathToApp/node_modules/appium/node_modules/.bin/authorize-ios'
10654 error enoent This is most likely not a problem with npm itself
10654 error enoent and is related to npm not being able to find a file.
10655 verbose exit [ -2, true ]