Cannot run yarn appium


#1

rydes-mac-mini:react-mobile-app ryde$ yarn run appium
yarn run v1.10.1
$ appium
[Appium] Welcome to Appium v1.9.1
Fatal TypeError: Class constructor BaseDriver cannot be invoked without ‘new’
at new AppiumDriver (/Users/ryde/Desktop/react-mobile-app/node_modules/appium/lib/appium.js:131:19)
at main$ (/Users/ryde/Desktop/react-mobile-app/node_modules/appium/lib/main.js:124:16)
at tryCatch (/Users/ryde/Desktop/react-mobile-app/node_modules/appium/node_modules/babel-runtime/regenerator/runtime.js:67:40)
at GeneratorFunctionPrototype.invoke [as _invoke] (/Users/ryde/Desktop/react-mobile-app/node_modules/appium/node_modules/babel-runtime/regenerator/runtime.js:315:22)
at GeneratorFunctionPrototype.prototype.(anonymous function) [as next] (/Users/ryde/Desktop/react-mobile-app/node_modules/appium/node_modules/babel-runtime/regenerator/runtime.js:100:21)
at GeneratorFunctionPrototype.invoke (/Users/ryde/Desktop/react-mobile-app/node_modules/appium/node_modules/babel-runtime/regenerator/runtime.js:136:37)
at
error Command failed with exit code 2.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.