Error: Bad app. App paths need to be absolute

I am using appium 1.5.0 version in mac 10.10.5

An unknown server-side error occurred while processing the command. Original error: Bad app: /Users/sdc/bamboo-agent-home/xml-data/build-dir/CIA-ADSI-ART/sample-app/build/test.ipa. App paths need to be absolute, or relative to the appium server install dir, or a URL to compressed file, or a special app name. (Selenium::WebDriver::Error::UnknownError)

when i used below command in terminal I get positive response back to test if file does exists in this path.
stat /Users/sdc/bamboo-agent-home/xml-data/build-dir/CIA-ADSI-ART/sample-app/build/test.ipa

we are trying to run in bamboo but getting bad app error. There are lots of discussion but no definitive answer. Can you please clarify if this is a bug in appium itself? we are running tests in iphone 5 iOS 8

when we did it with bamboo we managed to run it by coping builded file into another folder e.g. ‘/Users/test_clients/’

Bamboo do build -> after build succeed we copy build file to artifact + copy with overwrite build to ‘/Users/test_clients/’.

In Appium tests we use this ‘/Users/test_clients/’ url to test clients builds.

@Aleksei Cool I will try that. Any particular reason we need to do this way?

no idea. just more convenient.

  1. you have artifact with client build
  2. you can replace build directly on machine whatever like to test (maybe not new one but some earlier version)
  3. you do not care where actually path to agent to find out builded build
  4. you do not care about build name “test-debug.ipa”. when copy happens do always rename to “test.ipa”

i got exactly same error again :frowning: any more suggestion? I think issue seems to be on appium side. @jlipps

can you manually install this ipa build on phone using same path to build in command line?

@Aleksei I am running it on build machine so I can’t be sure if I can run it manually same command line there. However I have tried to download the same generated ipa file and able to run it on my local machine on same device successfully.

so you downloaded that file. you can now do same test locally on your machine to check if everything is working. just update path to ipa file OR use same as i suggested ‘/Users/test_clients/’ with your machine too.

run your test in same way as in Bamboo e.g. mvn test…

@Aleksei I have tried that and it works on my local machine. Its issue only in Bamboo that it cannot find ipa somehow.

so the problem is only in Bamboo machine where agent running on mac.

you can’t connect to it and execute your tests manually there? check config… and so on?

i have added lots of debug to see all info i need. Verified if ipa file exists inside build folder. Don’t know where it is going wrong.

build 18-May-2016 14:44:48 -rw-r–r-- 1 test test 7243560 18 May 15:44 test.ipa

44:48 + appium-doctor --ios
18-May-2016 14:44:49 info AppiumDoctor ### Diagnostic starting ###
18-May-2016 14:44:49 info AppiumDoctor ✔ Xcode is installed at: /Applications/Xcode.app/Contents/Developer
18-May-2016 14:44:49 info AppiumDoctor ✔ Xcode Command Line Tools are installed.
18-May-2016 14:44:49 info AppiumDoctor ✔ DevToolsSecurity is enabled
18-May-2016 14:44:49 info AppiumDoctor ✔ The Authorization DB is set up properly.
18-May-2016 14:44:49 info AppiumDoctor ✔ The Node.js binary was found at: /usr/local/bin/node
18-May-2016 14:44:49 info AppiumDoctor ✔ HOME is set to: /Users/test
18-May-2016 14:44:49 info AppiumDoctor ### Diagnostic completed, no fix needed. ###
18-May-2016 14:44:49 info AppiumDoctor
18-May-2016 14:44:49 info AppiumDoctor Everything looks good, bye!