Error: Chromedriver create session did not work

May be this correlates with issue: https://github.com/appium/appium/issues/2841

@arikon

I had the same problem with the chromedriver version provided by appium.
Try using chromedriver v2.3 .
It worked for me. Also remove the chromedriver.exe from task manager if present.

Cheers

@Ram & @arikon

How does one override the ChromeDriver version provided by Appium? I’m running into similar issue with ChromeDriver and Appium 1.2.2 (reference Chrome not reachable error)

@rstagner

Go to this folder and replace the chromedriver in the respective folder of your operating system there with whichever version you want

—> Appium\node_modules\appium\build\chromedriver\

Hi,
I have also run into same issue on MAc 10.9.5 running Nexus 10 Genymotion emulator with Android version 4.4.4.

I am using Downloaded Appium app version : 1.3.1
Can some one explain in more detail how do we solve this.

JFYI - same issue been tracked here as well - https://code.google.com/p/chromedriver/issues/detail?can=2&start=0&num=100&q=&colspec=ID%20Status%20Pri%20Owner%20Summary&groupby=&sort=&id=845

Hi @RamS - Is there any other way to skip this issue??

Hi @PRABU90,
I could get my current test case working with Appium upgrade to 1.3.1 and Java client to 1.6.3
Not sure if this has solved the main problem. Once I start working more on WebView, I will get clear picture. I will keep u posted on my findings.

Hi @Ram:
This issue gets resolved when i updated with latest chromedriver(v2.12). I’m also using the Appium v1.3.1 and java client v1.6.1. I can able to access the webviews in my hybrid application.

1 Like

Hi Ram ,
Can u please send me steps how to resolve this issue.can u please give briefly info if possible

@Jagatheskmp Is this sufficient information?

Sorry.I am new to appium chromedriver(v2.12) this is device chrome driver or system.i am confusing here.i am using Appium v1.3.1

Hi prabu,
Can u please give steps to update chromedriver.

@Jagatheskmp

You can download the most recent version here:

Put it in your appium/build/chromedriver directory.

Hi Mason,
Thanks a lot…I have downloaded chrome driver…where i can find the path appium/build/chromedriver

It’ll be wherever Appium is installed on your machine and that depends on your OS. You could try searching for a directory called “chromedriver”.

Hi Mason/Ram,
Thanks you very much…working fine now…

1 Like

Hi Mason/Ram,
I am not getting webview context in android version 4.3.Can u please give me solution for this.

Please give me solution for the above

Hi Mason.

Please kindly help for this ,

why java client v2.1.0 not supporting for this issue…

Please give me the solution for this.