Error: Device chrome not configured yet

Hi

My working environment is :
Mac OSX 10.10.3
Appium 1.3.7
I am testing mobile web on Chrome

When i launch Appium.app, i can run my test on real Android device with no issues.
My problem is, when i want to launch Appium from the command line, the test fails with error:

info: [debug] Appium successfully registered with the grid on 10.10.10.15:4444
info: --> POST /wd/hub/session {"desiredCapabilities":{"platform":"ANY","app":"Chrome","platformVersion":"4.3","javascriptEnabled":true,"acceptSslCerts":true,"platformName":"Android","deviceName":"gs4","browserName":"Chrome","name":"Html Player Test"}}
info: Client User-Agent string: undefined
info: [debug] The following desired capabilities were provided, but not recognized by appium. They will be passed on to any other services running on this server. : platform, javascriptEnabled, acceptSslCerts, name
error: Trying to run a session for device 'chrome' but that device hasn't been configured. Run config
info: [debug] Got configuration error, not starting session
info: [debug] Cleaning up appium session
error: Failed to start an Appium session, err was: Error: Device chrome not configured yet
info: [debug] Error: Device chrome not configured yet
    at [object Object].Appium.configure (/Users/shainter/appium/lib/appium.js:247:15)
    at [object Object].<anonymous> (/Users/shainter/appium/lib/appium.js:118:10)
    at [object Object].Appium.start (/Users/shainter/appium/lib/appium.js:129:5)
    at exports.createSession (/Users/shainter/appium/lib/server/controller.js:188:16)
    at Layer.handle [as handle_request] (/Users/shainter/appium/node_modules/express/lib/router/layer.js:82:5)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:110:13)
    at Route.dispatch (/Users/shainter/appium/node_modules/express/lib/router/route.js:91:3)
    at Layer.handle [as handle_request] (/Users/shainter/appium/node_modules/express/lib/router/layer.js:82:5)
    at /Users/shainter/appium/node_modules/express/lib/router/index.js:267:22
    at Function.proto.process_params (/Users/shainter/appium/node_modules/express/lib/router/index.js:321:12)
    at next (/Users/shainter/appium/node_modules/express/lib/router/index.js:261:10)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:100:14)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:104:14)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:104:14)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:104:14)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:104:14)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:104:14)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:104:14)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:104:14)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:104:14)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:104:14)
    at next (/Users/shainter/appium/node_modules/express/lib/router/route.js:104:14)
info: [debug] Responding to client with error: {"status":33,"value":{"message":"A new session could not be created. (Original error: Device chrome not configured yet)","origValue":"Device chrome not configured yet"},"sessionId":null}

I guess i am missing some configuration?

Thanks

Hi , Can i know which version of JDK are you using…

Thanks,

@sureshjashti

$ java -version
java version “1.6.0_65”
Java™ SE Runtime Environment (build 1.6.0_65-b14-466.1-11M4716)
Java HotSpot™ 64-Bit Server VM (build 20.65-b04-466.1, mixed mode)

Ok … Am using latest version of java i.e. version 8 in Windows and its working fine for me… Please try it with java version 8 and make relavent enviroment variable path changes correctly and check it once.

enter link description here

@sureshjashti

I tried with java 8, it did not help . i get the same error as before :disappointed:

$java -version
java version “1.8.0_45”
Java™ SE Runtime Environment (build 1.8.0_45-b14)
Java HotSpot™ 64-Bit Server VM (build 25.45-b02, mixed mode)

Did you find the solution to this? I need to run Appium 1.4.10 to troubleshoot an old issue and am seeing this error. My Java version is 1.8.0_66.