Ios:appium+ideviceinstaller test using .ipa failed

As the title, i’m using appium and ideviceinstaller to do automated test. I wrote a script to reinstall .ipa before test. Several
days ago, it worked well! But today, it suddenly failed. I don’t even know the reason. Here is the error report:

ideviceinstaller:

WARNING: could not locate iTunesMetadata.plist in archive!
WARNING: could not locate Payload/appname.app/SC_Info/appname.sinf in archive!

(The warning didn’t appear before.but i can run the app without appium.)

appium:

warn: Instruments socket client never checked in; timing out (global)

then retry three times but with the same error.

I have googled the problem, but without any result.

Any idea appreciated~~

I’m using appium1.3.4, xcode6.1.

Have you tried rebuilding the application with Xcode, and then Rebuilding again with the ideviceinstaller? I had an issue similar to this scenario where I had things running, but ended up having to rebuild the application, and then redeploy the application to the device again. Eventually it started working again.

yes, i have tried to restart and rebuild. but it doesn’t help. It really troubles me so much.

okay, it seems that appium would fail with any signed app now! This didn’t happen before. I’m totally confused now.
Any idea appreciated!