iOS - Strong password cover text intermittently breaking tests

Hey everyone,

Running into a bit of a headache with iOS. I’m using with appium. This happens once every 30 tests and just fixes itself on the retry. Once it enters the password into the field it comes up with this strong password cover which then bugs out the password field, since it for some reason thinks that there are less than 6 characters in the field.

Has anyone run into this kind of issue? This never happens when manually testing the app so I’m not sure if this is an issue with the app or an issue with appium itself. I’ve tried using both setValue and addValue. As well as tapping the field into focus before entering the password. Still, this intermittently happens. (Running on iOS Simulator, latest XCode version).


how you enter text into this field?

try logic as user:

  • tap on password input
  • send text with keyboard
// Java
new Actions(driver).sendKeys(text).perform();

Quite often sendKeys to element does not work correctly. Much depends on how app written.

Hey Aleksei, thanks for your reply.

I’ve tried doing this way too and still get this strong password cover text. Not sure how else to get round this. It seems to always happen when its a fresh simulator session.

I am having this problem too. I’m using an iPhone 15 Pro, iOS 17.2 simulator.

I set the password field using:

const value = 'MyFakePassword123'
await buttonElement.addValue(value);

and it displays:

When I try to get the value right afterwards using

await buttonElement.getValue();

it prints out “•” and I am unable to submit the form because it thinks that the password is too short.

Thanks for any help with this!

As usual type with keyboard! Do not use set value here.

Thanks Aleksei, can you please explain what you mean by “type with keyboard”? I’m trying to automate this, not do it manually.

Thanks Aleksei. Unfortunately this isn’t an option on JS, which is what I’m using. I still haven’t found a way around this.

Is the OS generating this “cover” or is the browser showing it?

Hello everyone! I’m experiencing the same issue on the iOS 17.4 Simulator. Interestingly, I’m encountering this problem on an iMac 24 macOS 14.4.1 with an Apple M3, but everything works fine on a Mac mini macOS 14.4.1 with an Apple M2 Pro. I’ve tried different platform versions, reinstalling Xcode, and copying the simulator from the Mac mini to the iMac, but none of these steps have helped.