Left swipe is not working in Appium 1.3.4 on iOS 8.1 simulator?

Hi,

For me, left swipe is not working in 1.3.4 (java-client) on iOS 8.1 simulator.

Details:
Native app running on iOS 8.1 simulator
Appium version - 1.3.4
Java-client version - 2.1.0

I have tried different approaches as below:

  1. driver.swipe(286, 200, 10, 200, 2000); --> Actually it does “Right” direction swipe! (same behavior if I inter-change x co-ordinates)

  2. element.swipe(SwipeElementDirection.LEFT,1000); – > it also does “Right” direction swipe! (as good as giving SwipeElementDirection.RIGHT)

  3. TouchAction action = new TouchAction(driver);
    action.press(286, 200).waitAction(1000).moveTo(10, 200).release().perform(); —> it also does “Right” direction swipe!

  4. Using JavascriptExecutor - “mobile: swipe” —> It throws exception “Not yet implemented”

Can you please help me to simulate “Left” swipe?

Thanks.

even I’m having same problem not able to swipe tried multiple things but no luckwhat view are you trying to swipe?

Its Native view. And swipe up also not working for me…

I hope this is working in 2.2.0 and further.
Working on my side.

And really thanks @Surya_Dixit for stating the problem, referring the code shared, I could implement swipe action :smile: