Multiple appium processes question - SOLVED

Hey there,
I know this thread may be pretty common. I didn’t want to add to an older thread, so here goes:

Goal: To run multiple appium processes (1 iOS, 1 Android) simultaneously

  1. Steps I’ve tried:
    iOS: appium -a -p 4727 --no-reset -U “97a4dc9fd1b1d8aa125978bb3a5635268ad65bb0”
    Android: similar command but made a -p at least 2 digits away.
    Expected Behavior: appium starts and my tests can run against this appium server.
    Actual Result: appium starts , but kicking off my tests = ERROR: Unable to connect to Appum.

Appium Process is up and running successfully
Right now, due to resources and timing, I’m not able to investigate time with selenium grid. it’s on the todo list though.

I’m wondering if anyone has any other thoughts. I’ll see if there are any port conflicts. I’ll also keep trundling through the archived topics here, the online docs and the legacy Appium google group.

Thanks in advance!

Eric, forgive the basic questions, but let’s make certain you are doing all the basic things correclty.

When you start up your client, are you connecting to the specific port you set when you start the server?
Are you able to connect to Appium using the default port?

I can connect to appium using the default port and run my tests fine.
I wasn’t sure if I also had to specify the port in my desired capabilities somewhere. I didn’t see that listed. That may be my problem :slight_smile:

@willosser, you were right.
Thanks to this post for helping me out!