newCommandTimeout

I am using newCommandTimeout in Json for launching my node.

but i am unable to override the default value for the newCommandTimeout which is 60 secs.

I am using the latest appium version 1.5.2 for testing iOS app v9.

We used command-timeout for the same purpose in the in version 1.4.13

Can someone provide details of how to override newCommandTimeout value?

@Dennis_Richards Could you paste the entire command you are using to launch appium ?

It would also be nice to post the actual code used to build your desired capabilities object. Appium 1.5 expects certain parameters to match the type they should appear in e.g. integers should be JSON integers, strings should be JSON strings, etc.

This is my node config json:
{
“capabilities”:
[
{
“browserName”: “iphone”,
“platform”:“MAC”,
“platformName”:“iOS”,
“deviceName”:“iphone”,
“newCommandTimeout”:“15000”
}
],
“configuration”:
{
“cleanUpCycle”:8000,
“timeout”:300000,
“proxy”: “org.openqa.grid.selenium.proxy.DefaultRemoteProxy”,
“url”: “hub url”,
“host”: “host ip”,
“port”: 4724,
“maxSession”: 1,
“register”: true,
“registerCycle”: 10000,
“hubPort”: 4444,
“hubHost”: “hubhost url”,
“hub”: “hubhosturl:4444/grid/register”,
“remoteHost”: “remotehost:4724”,
“role”: “node”
}
}

This is command line used for appium server:

appium --nodeconfig ./iPhone6_1.json --tmp /tmp/ios6/ --port “4724” --newCommandTimeout “150000” --debug-log-spacing --platform-version “8.1” --platform-name “iOS” --udid “udidofmyphone” --show-ios-log --device-name “iPhone 6”

but this did not work so i used:
appium --nodeconfig ./iPhone6_1.json --tmp /tmp/ios6/ --port “4724” --command-timeout “150000” --debug-log-spacing --platform-version “8.1” --platform-name “iOS” --udid “udidofmyphone” --show-ios-log --device-name “iPhone 6”

Here i know command-timeout is deprecated.

@Dennis_Richards Can you try adding below flag to appium server command and check ?

--default-capabilities "{\"newCommandTimeout\": \"150\"}"

Do remove --newCommandTimeout "150000"

1 Like

Thanks @hemche. Now i am able override the default value for newCommandTimeout

1 Like