No uiautomator process found to kill, continuing & Shutting down UiAutomator

Hi ,

I can able to run the IOS test cases, but when I tried to run Android Emulator, emulator state Shutting down UiAutomator. Please find the below details of desired capabilites and logs.

exports.android19 = {
browserName: ‘’,
‘appium-version’: ‘1.5’,
platformName: ‘Android’,
platformVersion: ‘6.0’,
deviceName: ‘emulator-5554’,
newCommandTimeout:180,
noReset:true,
automationName: ‘Appium’,
app: undefined // will be set later
};

appium >> [debug] [MJSONWP] Calling AppiumDriver.getContexts() with args: [“7c7f40f7-8e30-403f-a73e-fecfeea4cd30”]

appium >> [debug] [AndroidDriver] Getting a list of available webviews

appium >> [debug] [ADB] Getting connected devices…

appium >> [debug] [ADB] 1 device(s) connected
[debug] [ADB] Running ‘/Users/praveen/Library/Android/sdk/platform-tools/adb’ with args: [“-P”,5037,“-s”,“emulator-5554”,“shell”,“cat”,“/proc/net/unix”]

appium >> [debug] [AndroidDriver] Found webviews:

appium >> [debug] [AndroidDriver] Available contexts: [“NATIVE_APP”]

appium >> [debug] [MJSONWP] Responding to client with driver.getContexts() result: [“NATIVE_APP”]

RESPONSE contexts() [“NATIVE_APP”]
appium >> [HTTP] ← GET /wd/hub/session/7c7f40f7-8e30-403f-a73e-fecfeea4cd30/contexts 200 110 ms - 86

appium >> [BaseDriver] Shutting down because we waited 180 seconds for a command

appium >> [debug] [AndroidDriver] Shutting down Android driver
[Appium] Closing session, cause was ‘New Command Timeout of 180 seconds expired. Try customizing the timeout using the ‘newCommandTimeout’ desired capability’
[Appium] Removing session 7c7f40f7-8e30-403f-a73e-fecfeea4cd30 from our master session list
[debug] [ADB] Getting connected devices…
[debug] [ADB] 1 device(s) connected
[debug] [ADB] Running ‘/Users/praveen/Library/Android/sdk/platform-tools/adb’ with args: [“-P”,5037,“-s”,“emulator-5554”,“shell”,“am”,“force-stop”,“com.vertafore.dev.ams360”]

appium >> [debug] [ADB] Pressing the HOME button

appium >> [debug] [ADB] Getting connected devices…

appium >> [debug] [ADB] 1 device(s) connected

appium >> [debug] [ADB] Running ‘/Users/praveen/Library/Android/sdk/platform-tools/adb’ with args: [“-P”,5037,“-s”,“emulator-5554”,“shell”,“input”,“keyevent”,3]

appium >> [debug] [AndroidBootstrap] Sending command to android: {“cmd”:“shutdown”}

appium >> [AndroidBootstrap] [BOOTSTRAP LOG] [debug] Got data from client: {“cmd”:“shutdown”}

appium >> [AndroidBootstrap] [BOOTSTRAP LOG] [debug] Got command of type SHUTDOWN

appium >> [AndroidBootstrap] [BOOTSTRAP LOG] [debug] Returning result: {“status”:0,“value”:“OK, shutting down”}

appium >> [AndroidBootstrap] [BOOTSTRAP LOG] [debug] Closed client connection
[debug] [AndroidBootstrap] [UIAUTO STDOUT] INSTRUMENTATION_STATUS: numtests=1
[debug] [AndroidBootstrap] [UIAUTO STDOUT] INSTRUMENTATION_STATUS: stream=.
[debug] [AndroidBootstrap] [UIAUTO STDOUT] INSTRUMENTATION_STATUS: id=UiAutomatorTestRunner
[debug] [AndroidBootstrap] [UIAUTO STDOUT] INSTRUMENTATION_STATUS: test=testRunServer

appium >> [debug] [AndroidBootstrap] [UIAUTO STDOUT] INSTRUMENTATION_STATUS: class=io.appium.android.bootstrap.Bootstrap
[debug] [AndroidBootstrap] [UIAUTO STDOUT] INSTRUMENTATION_STATUS: current=1

appium >> [debug] [AndroidBootstrap] [UIAUTO STDOUT] INSTRUMENTATION_STATUS_CODE: 0

appium >> [debug] [AndroidBootstrap] Received command result from bootstrap

appium >> [debug] [UiAutomator] Shutting down UiAutomator

appium >> [debug] [UiAutomator] Moving to state ‘stopping’

appium >> [debug] [UiAutomator] UiAutomator shut down normally

appium >> [debug] [UiAutomator] Moving to state ‘stopped’

appium >> [debug] [ADB] Attempting to kill all uiautomator processes

appium >> [debug] [ADB] Getting all processes with uiautomator

appium >> [debug] [ADB] Getting connected devices…

appium >> [debug] [ADB] 1 device(s) connected

Thanks
Praveen.B