noDevicesError no devices found

Hi,
I am running appium 1.4.16 from terminal on my mac mini.

"Welcome to Appium v1.4.16 (REV bce540be133b45b82229477d941d42598ef5ecae)"

My iOS project is built and deployed from here. I have a windows machine that will be running c# tests remotely against this machine.

I think I have it all configured correctly with the correct path to the app etc but for some reason when I run the tests from windows the mac always returns with a 500 saying that no devices were found

[debug] Responding to client with error: {"status":33,"value":{"message":"A new session could not be created. (Original error: Could not find a device to launch. You requested 'iPhone 5s (9.1)', but the available devices were: [])","origValue":"Could not find a device to launch. You requested 'iPhone 5s (9.1)', but the available devices were: []"},"sessionId":null}
info: <-- POST /wd/hub/session 500 776.976 ms - 326 

The test is configured with the following

testCapabilities.App = "/Users/Bob/PathToApp/AmazingApp.app";
testCapabilities.AutoWebView = true;
testCapabilities.AutomationName = "";
testCapabilities.DeviceName = "iPhone 4s";
testCapabilities.Platform = TestCapabilities.DevicePlatform.IOS; 
testCapabilities.PlatformVersion = "8.1"; 

 testCapabilities.AssignAppiumCapabilities(ref capabilities);
 driver = new IOSDriver(remoteServerAddress, capabilities, INIT_TIMEOUT_SEC);
 driver.Manage().Timeouts().ImplicitlyWait(IMPLICIT_TIMEOUT_SEC);

Xcode version is 7.1.1

When I run xcrun simctl list I see a full list of all devices and os versions but ios.js can never find any.

Can anyone help me with this.

Cheers

Gav

Update: I also have Xcode 6 installed. For when I wanted to check an iOS7 build. I just changed the command line tools to Xcode 6.4 and use an iOS version supported by Xcode 6 such as 8.4 it all works fine. I can run the remote tests and it finds the simulator.

Is there anyway to run Appium when I have 2 versions of Xcode installed? is it possible to get it to work with Xcode 7 command line tools while Xcode 6 is also installed?