Not able to click on Search button {BigBasket}

Here is an Appium log:

[AndroidDriver] App file was not listed, instead we’re going to run com.bigbasket.mobileapp directly on the device
[debug] [AndroidDriver] Checking whether package is present on the device
[debug] [ADB] Getting connected devices…
[debug] [ADB] 1 device(s) connected
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“shell”,“pm”,“list”,“packages”,“com.bigbasket.mobileapp”]
[AndroidDriver] Starting Android session
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“wait-for-device”]
[debug] [ADB] Getting connected devices…
[debug] [ADB] 1 device(s) connected
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“shell”,“echo”,“ping”]
[debug] [Logcat] Starting logcat capture
[debug] [AndroidDriver] Pushing settings apk to device…
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“install”,"/Applications/Appium.app/Contents/Resources/node_modules/appium/node_modules/appium-android-driver/node_modules/io.appium.settings/bin/settings_apk-debug.apk"]
[debug] [AndroidDriver] Pushing unlock helper app to device…
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“install”,"/Applications/Appium.app/Contents/Resources/node_modules/appium/node_modules/appium-android-driver/node_modules/appium-unlock/bin/unlock_apk-debug.apk"]
[ADB] Getting device platform version
[debug] [ADB] Getting connected devices…
[debug] [ADB] 1 device(s) connected
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“shell”,“getprop”,“ro.build.version.release”]
[debug] [ADB] Getting connected devices…
[debug] [ADB] 1 device(s) connected
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“shell”,“dumpsys”,“window”]
[AndroidDriver] Screen already unlocked, doing nothing
[debug] [AndroidBootstrap] Watching for bootstrap disconnect
[debug] [ADB] Forwarding system: 4723 to device: 4724
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“forward”,“tcp:4723”,“tcp:4724”]
[debug] [UiAutomator] Starting UiAutomator
[debug] [UiAutomator] Moving to state ‘starting’
[debug] [UiAutomator] Parsing uiautomator jar
[debug] [UiAutomator] Found jar name: ‘AppiumBootstrap.jar’
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“push”,"/Applications/Appium.app/Contents/Resources/node_modules/appium/node_modules/appium-android-driver/node_modules/appium-android-bootstrap/bootstrap/bin/AppiumBootstrap.jar","/data/local/tmp/"]
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“forward”,“tcp:4723”,“tcp:4724”]
[debug] [ADB] Attempting to kill all uiautomator processes
[debug] [ADB] Getting all processes with uiautomator
[debug] [ADB] Getting connected devices…
[debug] [ADB] 1 device(s) connected
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“shell”,“ps”,“uiautomator”]
[ADB] No uiautomator process found to kill, continuing…
[debug] [UiAutomator] Starting UIAutomator
[debug] [ADB] Creating ADB subprocess with args: -P, 5037, -s, 3bc73ef5, shell, uiautomator, runtest, AppiumBootstrap.jar, -c, io.appium.android.bootstrap.Bootstrap, -e, pkg, com.bigbasket.mobileapp, -e, disableAndroidWatchers, false, -e, acceptSslCerts, false
[debug] [UiAutomator] Moving to state ‘online’
[AndroidBootstrap] Android bootstrap socket is now connected
[debug] [ADB] Getting connected devices…
[debug] [ADB] 1 device(s) connected
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“shell”,“getprop”,“ro.build.version.sdk”]
[AndroidBootstrap] [BOOTSTRAP LOG] [debug] json loading complete.
[AndroidBootstrap] [BOOTSTRAP LOG] [debug] Registered crash watchers.
[debug] [ADB] Device API level: 19
[debug] [ADB] Getting connected devices…
[debug] [ADB] 1 device(s) connected
[debug] [ADB] Running /Users/webyog/Library/Android/sdk/platform-tools/adb with args: ["-P",5037,"-s",“3bc73ef5”,“shell”,“am”,“start”,"-n",“com.bigbasket.mobileapp/com.bigbasket.mobileapp.activity.SplashActivity”,"-S","-a",“android.intent.action.MAIN”,"-c",“android.intent.category.LAUNCHER”,"-f",“0x10200000”]
[Appium] New AndroidDriver session created successfully, session a2d833ce-0afc-4cd1-b87f-89d8bf624346 added to master session list
[MJSONWP] Responding to client with driver.createSession() result: {“platform”:“LINUX”,“webSto…
[HTTP] <-- POST /wd/hub/session 200 13054 ms - 687
[HTTP] --> POST /wd/hub/session/a2d833ce-0afc-4cd1-b87f-89d8bf624346/element {“using”:“id”,“value”:“com.bigbasket.mobileapp:id/action_search”}
[MJSONWP] Calling AppiumDriver.findElement() with args: [“id”,“com.bigbasket.mobile…
[debug] [BaseDriver] Waiting up to 0 ms for condition
[debug] [AndroidBootstrap] Sending command to android: {“cmd”:“action”,“action”:“find”,“params”:{“strategy”:“id”,“selector”:“com.bigbasket.mobileapp:id/action_search”,“context”:””,“multiple”:false}}

P.S: It happens if I start Appium server through the code and try to click on search button. Suppose, if I use Appium GUI to launch the server and run the code, it goes fine without any issue.

Can someone help me? I am on Mac El Captain.

What does your code look like? If you are specifying “click” in your code, I think you should see a server message similar to:
Got data from client: {“cmd”:“action”,“action”:“element:click”,“params”:{“elementId”:“1”}}

Thanks for the response, Leppo. Have a look on the code which I have written:

Start_server();
Init_app();

WebDriverWait wait = new WebDriverWait(driver, 60);
wait.until(ExpectedConditions.presenceOfElementLocated(By.id("com.bigbasket.mobileapp:id/action_search")));

//Identify the elements
driver.findElementById("com.bigbasket.mobileapp:id/action_search").click();
Thread.sleep(2000);

driver.findElementById("com.bigbasket.mobileapp:id/searchView").sendKeys("aaaaa");
Thread.sleep(2000);

driver.sendKeyEvent(AndroidKeyCode.ENTER);

String invalid_msg = driver.findElementById("com.bigbasket.mobileapp:id/txtEmptyMsg1").getText();
System.out.println(invalid_msg);


stop_server();

It is happening only if I run start server through code. If I launch the server manually it works fine.