parsedUrl has no method "original"

I’m using Appium 1.4.0 (Ophiuchus) and have npm 1.46, attempting to start a Droid phone using Droid OS 4.4.2. I’ve also tried on a Droid 5.0 phone, although I suspect that support for that phone is not available yet. In both cases, the code to start the phone is the same. Both devices have Chrome, the code below is C#.

public void SetUpDroid(string version)
{
    if (driver != null) return;
    caps = DesiredCapabilities.Android();
    
    caps.SetCapability(CapabilityType.Platform, "Android");
    caps.SetCapability(CapabilityType.Version, version);
    caps.SetCapability(CapabilityType.BrowserName, "chrome");
    caps.SetCapability("deviceName", "Android");
    caps.SetCapability("platformName", "Android");
    driver = new AppiumDriver(new Uri("http://127.0.0.1:4723/wd/hub"), caps, span);
    driver.Manage().Timeouts().ImplicitlyWait(span);
    driver.Manage().Timeouts().SetPageLoadTimeout(span);
}

I’ve used Appium before on older devices and it’s worked fine, but I no longer have access to that device. With my new Droid device (literally, out of the box new), I get the following:

TypeError: Object function parseUrl(req){
var parsed = req._parsedUrl

if (fresh(req, parsed)) {
return parsed
}

parsed = fastparse(req.url)

if (parsed.auth && !parsed.protocol && parsed.href.indexOf('//') !== -1) {
// This parses pathnames, and a strange pathname like //r@e should work
parsed = fastparse(req.url.replace(/@/g, '%40'))
}

return req._parsedUrl = parsed
} has no method 'original'
at serveStatic (C:\emulation\Appium\node_modules\appium\node_modules\express\node_modules\serve-static\index.js:63:32)
at Layer.handle as handle_request
at trim_prefix (C:\emulation\Appium\node_modules\appium\node_modules\express\lib\router\index.js:302:13)
at C:\emulation\Appium\node_modules\appium\node_modules\express\lib\router\index.js:270:7

Any help you can provide would be appreciated. Thanks in advance.

I have never used set up u r using. But I have below observations based on code u shared

// device name is passed as static string “Android”, I hope this could not be the exact device name which is attached
caps.SetCapability(“deviceName”, “Android”);

Also caps.SetCapability(CapabilityType.BrowserName, “chrome”); should be
caps.setCapability(CapabilityType.BROWSER_NAME,“Chrome”); // for Chrome
caps.SetCapability(CapabilityType.BROWSER_NAME,“Browser”); // for native browser of device