Real device issue in iOS 13.4 and xcode 11.2

Hi Team,

I am stuck over a week on a particular issue.

the problem: app loses registration data when IOS driver is initialized.

QA capabilities used:
setCapability(“autoLaunch”, true);
setCapability(“noReset”, true);
setCapability(“newCommandTimeout”, 600);
setCapability(“udid”, “XXXX”);
setCapability(“deviceName”, “dev_XXXX”);
setCapability(“userIdx”, -1); // to be overwritten
setCapability(“clearSystemFiles”, true);
setCapability(“platformName”, “iOS”);
setCapability(“platformVersion”, “XXX”);
setCapability(“automationName”, “XCUITest”);
setCapability(“deviceName”, “iPhone X”);
setCapability(“xcodeSigningId”, “iPhone Developer”);
setCapability(“xcodeOrgId”, “AAAAAAAAA”);
setCapability(IOSMobileCapabilityType.USE_NEW_WDA, false);
setCapability(“app”, “XXXX”);
setCapability(“bundleId”, “XXXX”);

I have WDA running on my device, but on iOS driver initialization the app loses its registration and shows up the login page again.

device : iphone xs - ios 13.4

xcode : 11.2

appium: 1.15.0 , tried 1.16.0 and 1.17.0 as well

Please let me know if I am missing something.

I have tried to everything possible at my end

Try to play using 2 reset parameters -> Different capabilities for different scenarios

1 Like

thanks a ton, I will try it now, just in between android automation

It makes no sense to provide app cap if noReset is set to true, because noReset already assumes the app is installed on the device. Only bundleId should be provided

Hi @Aleksei and @mykola-mokhnach , I tried both capabilities, even every capability possible, but still everytime my iOS driver initializes it clears the registration data in the app.

This is causing us pain, and blocking the automation severely

Check out with developers where the app persists auth data and what may cause this data to be reset. Also, ask devs to add more debug logs to figure out how automated runs are different from manual ones

1 Like

@mykola-mokhnach we are kind of working as a independent team, so very rarely we interact with the devs. Has anyone faced similar case in iOS 13.4 and xcode 11.2