Safari on iOS, ios_webkit_debug crashing when SafariLauncher launches Safari

Hi @Venkatesh

Get the appium source from github, go to terminal > navigate to ur cloned appium folder and run the command
./bin/ios-webkit-debug-proxy-launcher.js -cUDID -d
ios-webkit-debug-proxy-launcher.js takes care of the crashing issue.

Amarnath Rayudu

Thanks Amarnath,

Your comment helped me out.It worked for me.


My Pleasure @Amit_Sharma :slight_smile:

@AmarnathRayudu Thanks, i was struggling with this until i got hold of this post.

Hi All,

I was also facing this webkit crashing issue and trying its work around “./bin/ios-webkit-debug-proxy-launcher.js -c :27753 -d”

first i did “cd /usr/local/bin” on terminal
then “ios-webkit-debug-proxy-launcher.js -c ca666e295c7cd5a893e376989f3c4a3b24987534:27753 –d”

it says "command not found "

can someone please help me , do we need to separate install this js file or where I can find this on my mac


Try installing ios-webkit-debug-proxy from brew.


iOS-web-kit-debug-proxy connects and disconnects with rpc server immediately.
On running the Appium code on hybrid app, works well on native pages, but fails while switching to the web context.
Error Message on Appium log: Could not connect to WebKitRemoteDebugger server
Responding to client with error: {“status”:clock13:

This issue occurs both with iOS-web-kit-debug-proxy through appium/bin launcher and home-brew

Appium : 1.3.4
iOS device : 7.1
Xcode Version: 7.1
OSx Version: 10.10


I am also facing the same issue. It installs Safarilauncher, opens safari browser but did not hit my URL. did you get any solution for it?

can you pls help on this.

deviceUDID= xx
appium-version =1.4.11
browserName =Safari
platformName =iOS
deviceName =iPhone 6
platformVersion =8.4

OS El capitan- 10.11
xcode 6.4

HI Jchuong,

Can you plz help where i will get the ios-webkit-debug-proxy-launcher.js

i tried to git clone but it not work.

No need to run js, install it from brew
brew install ios-webkit-debug-proxy

Hi, I am getting this error while running : ./bin/ios-webkit-debug-proxy-launcher.js -cUDID -d

./bin/ios-webkit-debug-proxy-launcher.js -c :27753 -d
throw err;
Error: Cannot find module ‘underscore’
at Function.Module._resolveFilename (module.js:336:15)
at Function.Module._load (module.js:278:25)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Object. (/appium/bin/ios-webkit-debug-proxy-launcher.js:22:9)
at Module._compile (module.js:460:26)
at Object.Module._extensions…js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Function.Module.runMain (module.js:501:10)

Any suggestions on this? Thanks!