[Solved] 'Current Location' modal is not accessible with new appium-xcuitest-driver update

I was able to click ‘Allow Once’ by accessibilityID ‘~Allow Once’ with 5.16.1 xcuitest-driver version. Unable to do so with the latest driver version. This modal is not accessible at all. Please help!
I tried enableMultiWindows and driver.acceptAlert - no luck.
Native iOS app - no other Contexts.

Listing installed drivers

Appium version v2.5.4
Node version v18.12.1

{
  "platformName": "iOS",
  "appium:deviceName": "iPhone 15",
  "appium:platformVersion": "17.0",
  "appium:app": "*******",
  "appium:fullReset": false,
  "appium:automationName": "XCUITest",
  "appium:autoAcceptAlerts": true,
  "appium:noReset": true,
  "appium:bundleId": ***,
}

It looks like it stopped working from v6.0.0 - so the next release after 5.16.1.

@mykola-mokhnach, thank you but respectSystemAlerts capability doesn’t help.
So I have to activateApp(‘com.apple.springboard’) every time I want to interact with the modal and then activateApp(‘my.bundleId’) back every time?

it is not a capability, it’s a setting.

@mykola-mokhnach, thank you. I see now, set that via capabilities :slight_smile:

@mykola-mokhnach, If I use this setting in the Appium GUI inspector - it works fine, elements are accessible. When I use it in the code - it does not recognize elements, page source doesn’t show its elements. Any suggestions?
Appium 2.5.4

Make sure you use the most recent driver and server versions

1 Like

Updated appium-xcuitest-driver to 7.23.1 and working now.