Unable to click on button in iPad Safari

Hi, I am not able to perform click operations on a few of the buttons in iPad Safari.
Even though button isDisplayed = true,
However, the same script works fine for iOS(Safari). Previously, the same script worked fine for iPad as well. However, the click issue has been present from few weeks.
Tap operation fails in the Appium inspector as well.
I even tried Javascript click and touch action tap as well, although I was not able to perform the click operation.
Platform - iOS
Device - iPad
Browser - Safari
Device - Saucelab
Application - Responsive(Webview )

I don’t work with webviews usually but, it sounds like you did not change the context from native to webview…
see here: https://appium.io/docs/en/commands/context/set-context/
and https://appium.io/docs/en/writing-running-appium/web/hybrid/index.html

might be related as well: https://appium.io/docs/en/writing-running-appium/web/hybrid/index.html#:~:text=Unfortunately%2C%20it%20is%20not%20currently%20able%20to%20handle%20SafariViewController%20elements.

1 Like