Unable to install appium 1.5 version on windows 7/ windows 8

Hi,

I am unable to install appium higher versions( 1.4.1-1.5), facing Appium chromedriver installation issue.
But I could install appium 1.5 on windows 10 machine.

Environment

  • Desktop OS/version used to run Appium: windows 7 , windows 8
  • Node.js version (unless using Appium.app|exe): 3.6.0

Please find the below log,
C:\Users\JenkinServer\AppData\Roaming\npm\authorize-ios → C:\Users\JenkinServer
\AppData\Roaming\npm\node_modules\appium\node_modules.bin\authorize-ios
C:\Users\JenkinServer\AppData\Roaming\npm\appium → C:\Users\JenkinServer\AppDat
a\Roaming\npm\node_modules\appium\build\lib\main.js

[email protected] install C:\Users\JenkinServer\AppData\Roaming\npm\no
de_modules\appium\node_modules\appium-chromedriver
node install-npm.js

info Chromedriver Install Installing Chromedriver version ‘2.21’ for platform ‘w
in’ and architecture ‘32’
info Chromedriver Install Opening temp file to write chromedriver_win32 to…
info Chromedriver Install Downloading http://chromedriver.storage.googleapis.com
/2.21/chromedriver_win32.zip…
info Chromedriver Install Writing binary content to C:\Users\JENKIN~1\AppData\Lo
cal\Temp\201623-3824-1nfcyed\chromedriver_win32.zip…
info Chromedriver Install Extracting C:\Users\JENKIN~1\AppData\Local\Temp\201623
-3824-1nfcyed\chromedriver_win32.zip to C:\Users\JENKIN~1\AppData\Local\Temp\201
623-3824-1nfcyed\chromedriver_win32
Invalid or unsupported zip format. No END header found
C:\Users\JenkinServer\AppData\Roaming\npm
`-- (empty)

npm WARN optional Skipping failed optional dependency /appium/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fseve
[email protected]
npm ERR! Windows_NT 6.1.7601
npm ERR! argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\
node_modules\npm\bin\npm-cli.js” “install” “-g” “appium”
npm ERR! node v5.6.0
npm ERR! npm v3.6.0
npm ERR! code ELIFECYCLE

npm ERR! [email protected] install: node install-npm.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] install script ‘node install-np
m.js’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the appium-chromedriver p
ackage,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node install-npm.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs appium-chromedriver
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls appium-chromedriver
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! C:\Users\JenkinServer\npm-debug.log
npm ERR! code 1

Please help me out to resolve this issue.

Thanks,
Rashmi.

What tutorial are you following (please provide link) and what step does this fail on? Also, what is the command you have given that is failing?

Hi…

I am using below commands for installation,

Using Node.js
$ npm install -g appium
$ appium &

Appium-ChromeDriver download isn’t successful. So installation is not happening.

Command used is:$ npm install -g appium

Thanks,
Rashmi

Seems like an NPM problem. I did a quick Google search on npm, your error, and windows:

Seems like there are all kinds of problems to encounter. You don’t say what version of npm, so I won’t go into that. We clone the git repo, which works well, maybe that would be a good workaround for you?

hi…

thanks…

Had some download permission issue. Able to install now…

Hi @Rashmi,

If you know what the problem was could you post it here? It would help someone else when they have the same problem and are searching for an answer. Also, did the Google search help?

Hi…

Problem with installation was Appium-chromedriver was not downloading properly on giving installation command ** npm install -g appium**. It was downloading empty chrome-driver zip file in temp folder. As in installation requires chromedriver.exe so installation was unsuccessful. There was some download restriction on my company machine, once full download permission was given to system. Installation happened succcessfully.

Thanks…

1 Like

I am trying to update appium on windows 10 through command line but unable to succeed. getting following error