Unable to launch app with unlocked display (Fingerprint recognition enabled) in Coolpad Note 3

I am trying to run a simple script in Java Project to launch the Flipkart application in a real device and navigate to few category of items available. The device is kept in unlocked state and the display is active. The Fingerprint recognition is enabled. I am running the script using Eclipse IDE.
But the script fails to open the app, and at the end I am getting this issues:

info: [debug] Responding to client with error: {“status”:33,“value”:{“message”:“A new session could not be created. (Original error: com.flipkart.android/.SplashActivity never started. Current: com.yulong.android.launcher3/.Launcher)”,“origValue”:“com.flipkart.android/.SplashActivity never started. Current: com.yulong.android.launcher3/.Launcher”},“sessionId”:null}

info: ← POST /wd/hub/session 500 25490.826 ms - 320

Appium version: 1.4.16.1
Device under test: Coolpad Note 3

However I tried the same scenario in Moto Z Play with Fingerprint recognition enabled, and the script worked fine with no issues.

If anyone has any solution to this issue, please suggest.