When Appium New Version is going to release?

Hi Appium dev,

When is new version is expected to come with all fixes for Android/iOS ??

Please disclose some tentative date as I am eagerly waiting for new release. I am totally dependent on appium and stuck in middle cann’t move on to some other tool and as compared to appium no any other tool is friendly . So please disclose some new version release date . Hoping for the best.

Thanks in advance,
Nischal

I recommend learning how to run appium from source so you don’t have to wait for official releases.

I am running from source Appium 1.3.4 but still there is issue with Android for typing in text field and launching issue on iOS real device.

Can you clarify and point to open issues on githut or at least at one open discussion about the issue

Hi Telmo,

Please find the open issues for both Android and iOS:

1. [Android - sendKeys() function clicks/taps random elements in the page but does not enter text in the EditText element]

2. Currently I am getting this issue on iOS real device iPhone 5s [ iOS 8.1.2 ]

[Move to ideviceinstaller. #3942]
https://github.com/appium/appium/issues/3942

Please find the latest logs with two trails on iOS device with installed App on real iOS device and without installing app on iOS device

1.Appium log without installing app on iOS device.txt (11.8 KB) <a class=“attachment”

  1. href="/uploads/default/517/7aba73ae92bdcded.txt">Log without installing app on real iOS devcie.txt (6.4 KB)

Thanks,
Nischal Sinha

But there is any issue open by you on githut? or that covers your issues and its not closed?

On your first log where you state its not installing I see:

info: [debug] Checking app install status using: /Users/nischalsinha/node_modules/appium/build/fruitstrap/fruitstrap isInstalled --id b9e94db749cdc65aa820902cc39c0c5f4a79ef34 --bundle com.cph.dev.Moonshot
info: [debug] App is installed.
info: [debug] fullReset not requested. No need to install.

The error is coming further below

info: [debug] [INST STDERR] 2015-01-05 21:11:52.997 instruments[1495:507] Failed to start Instruments daemon on 'iPhone (8.1.2)' (The service is invalid.)

The error is coming from instruments directly, it appears some problem with the device not being authorize for that developer certificate or other issue that sometimes happens in xCode. Check


or

Hi Telmo,

**1. First I tried installing my application in iOS real device iPhone 5s when my application was not available in device. Then i get the issue related to this below log . So this is basically the main issue.
Appium log without installing app on iOS device.txt (11.8 KB)

Copied from above log link to highlight the issue:

info: [debug] Couldn’t find ideviceinstaller, trying built-in at /Users/nischalsinha/node_modules/appium/build/libimobiledevice-macosx/ideviceinstaller
info: [debug] Cleaning up appium session
error: Failed to start an Appium session, err was: Error: Command failed: dyld: Library not loaded: @executable_path/…/lib/libimobiledevice.3.dylib
Referenced from: /Users/nischalsinha/node_modules/appium/build/libimobiledevice-macosx/ideviceinstaller
Reason: image not found

info: [debug] Error: Command failed: dyld: Library not loaded: @executable_path/…/lib/libimobiledevice.3.dylib
Referenced from: /Users/nischalsinha/node_modules/appium/build/libimobiledevice-macosx/ideviceinstaller
Reason: image not found

at ChildProcess.exithandler (child_process.js:648:15)
at ChildProcess.emit (events.js:98:17)
at maybeClose (child_process.js:756:16)
at Process.ChildProcess._handle.onexit (child_process.js:823:5)

Please clarify that now Appium v1.3.4 is normally working for iOS real device, is it able to install the application???

Thanks,
Nischal Sinha

The error you posting is different from whats on txt!

That error happened to me once and I solved it like this user:

You can also check:

Hi Telmo,

I am getting this error while installing Homebrew

ruby -e “$(curl -fsSL https://raw.github.com/mxcl/homebrew/go)”

curl: (7) Failed to connect to raw.github.com port 443: Connection refused

Any Idea???

Thanks…

Dunno… thats not appium anymore :smile:

Firewall probably. Have you tried htttp instead opf https?

Hi Telmo,

Thanks for your continuos support…

Now ideviceinstaller error is resolved but getting some other issue:

info: [debug] Attempting to run app on real device with UDID b9e94db749cdc65aa820902cc39c0c5f4a79ef34
info: [debug] Spawning instruments with command: /Applications/Xcode.app/Contents/Developer/usr/bin/instruments -t /Applications/Xcode.app/Contents/Applications/Instruments.app/Contents/PlugIns/AutomationInstrument.xrplugin/Contents/Resources/Automation.tracetemplate -D /tmp/appium-instruments/instrumentscli0.trace -w b9e94db749cdc65aa820902cc39c0c5f4a79ef34 com.cph.dev.Moonshot -e UIASCRIPT “/Users/nischalsinha/Library/Application Support/appium/bootstrap/bootstrap-df3ef93012789f00.js” -e UIARESULTSPATH /tmp/appium-instruments
info: [debug] And extra without-delay env: {}
info: [debug] And launch timeouts (in ms): {“global”:90000}
info: [debug] [INST STDERR] 2015-01-07 22:11:46.642 instruments[8275:124609] WebKit Threading Violation - initial use of WebKit from a secondary thread.

Thanks,
Nischal Sinha

Again, thats not related to appium… Its Instruments/XCode. Try to google for a solution, it will be more helpful than me trying to guess

Hi Telmo,

Issue resolved for iOS. We need to activate this Settings -->Developer–>Enable UI Automation to resolve above issue.

Thanks,
Nischal Sinha