Which Java-JDK need to use for Appium

Hi All,

I want to know which is the best stable Java-JDK version needs to be used for Appium Automation on both iOS and Android Platforms.

Warm Regards,
Rahamthulla