Why the hub is doing the registration with the node again and again

hub :

13:14:54.311 INFO - Registered a node http://127.0.0.1:4727
13:14:54.313 WARN - Cleaning up stale test sessions on the unregistered node http://127.0.0.1:4727
13:14:59.315 INFO - Registered a node http://127.0.0.1:4727
13:14:59.317 WARN - Cleaning up stale test sessions on the unregistered node http://127.0.0.1:4727
13:15:04.307 INFO - Registered a node http://127.0.0.1:4727
13:15:04.308 WARN - Cleaning up stale test sessions on the unregistered node http://127.0.0.1:4727
13:15:09.306 INFO - Registered a node http://127.0.0.1:4727
13:15:09.307 WARN - Cleaning up stale test sessions on the unregistered node http://127.0.0.1:4727
13:15:14.312 INFO - Registered a node http://127.0.0.1:4727
13:15:14.314 WARN - Cleaning up stale test sessions on the unregistered node http://127.0.0.1:4727
13:15:19.313 INFO - Registered a node http://127.0.0.1:4727

Please suggest if any one a else faced this kind of issue.

@MallikarjunaReddy.D

That looks like a configuration issue. What does your Appium nodeconfig file look like?

1 Like

@afwang
Node 1:

{
“capabilities”:[
{

“browserName”:"",
“deviceName”:“ZY2226S87X”,
“maxInstances”:4,
“platformName”:“ANDROID”
}
],
“configuration”:{
“cleanUpCycle”:5000,
“timeOut”:60000,
“hub”:“http://localhost:4444/grid/register/”,
“host”:“localhost”,
“proxy”:“org.openqa.grid.selenium.proxy.DefaultRemoteProxy”,
“maxSession”:5,
“port”:4727,
“hubPort”:4444,
“hubHost”:“localhost”,
“url”:“http://127.0.0.1:4727/wd/hub”,
“remoteHost”:“http://127.0.0.1:4727”,
“register”:true,
“registerCycle”:5000,
“role”:“node”

}
}

This is my node 1 config, as soon as i connect this node with the hub it give stale session connection issue.

hub :java -jar selenium-server-standalone-2.51.0.jar -role hub

node :node.exe Appium\node_modules\appium\bin\appium.js -–address 127.0.0.1 -–port 4727 -bp 2252 -–udid ZY2226S87X -–nodeconfig C:\shubham\json\node.json –-session-override