Xcode build works but appium hangs at splash screen while using Appium Inspector

I can build a local version of my app in Xcode and have it installed on my iPhone 7 Plus. The installed application works fine

However, I am unable to use appium inspector. The application will install to the Device, but then the app stays on the splash screen and unable to redirect to log in screen.

Before login screen, a prompt of Notification permission comes first.

[Appium-server-appium (2).log (31.0 KB)

Appium Inspector does not stay in sync with the app unless you’ve clicked a button or something similar. You must click refresh button at the splash screen.

I did click refresh button but no luck

What version Xcode are you using?

Also, capabilities are strange. Here is what you currently have:

“platformName”: “iOS”,
“appium:deviceName”: “Techliance iphone”,
“appium:platformVersion”: “15.7.9”,
“appium:udid”: “2e7a8a0177a97cdfe8ba5b4e55478b81d6269bd2”,
“appium:app”: “/Users/techliance/Downloads/flashop3.ipa”,
“appium:appPackage”: “com.flashop3”,
“appium:appActivity”: “com.flashop.flashop3.MainActivity”,
“appium:noReset”: “true”,
“appium:idleTimeOut”: “360”,
“appium:ImplicitlyWait”: “360”,
“appium:customSnapshotTimeout”: “250”,
“appium:snapshotMaxDept”: “500”,
“appium:includeSafariInWebviews”: true,
“appium:newCommandTimeout”: 3600,
“appium:connectHardwareKeyboard”: true

Try with just the minimal capabilities, and include automationName:

“platformName”: “iOS”,
“appium:platformVersion”: “15.7”,
“appium:deviceName”: “Techliance iphone”,
“appium:automationName”: “XCUITest”,
“appium:udid”: “2e7a8a0177a97cdfe8ba5b4e55478b81d6269bd2”,
“appium:app”: “/Users/techliance/Downloads/flashop3.ipa”

More on capabilities:

https://appium.github.io/appium.io/docs/en/writing-running-appium/caps/