Able to locate element in Appium but Unable to locate element while execution

Issue: Appium is able to locate element in Appium but is unable to view element on screen while execution (on iPhone).
See the Appium screenshot below.
Log is given after the screenshot.

Appium Server Version: 1.6.5
Appium Desktop Version: 1.1.1
Xcode Version: 8.3.3
iPhone OS: 10.2.1
Mac OS version: 10.13.4

[BaseDeviceControl] [ERROR] Error Domain=com.facebook.WebDriverAgent Code=1 “The element ‘“Create New Account” StaticText’ is not visible on the screen and thus is not interactable” UserInfo={NSLocalizedDescription=The element ‘“Create New Account” StaticText’ is not visible on the screen and thus is not interactable}
Command duration or timeout: 0 milliseconds
Build info: version: ‘3.6.0’, revision: ‘6fbf3ec767’, time: ‘2017-09-27T15:28:36.4Z’
System info: host: ‘—’, ip: ‘fe80:0:0:0:1081:66e1:630a:bca6%en0’, ‘Mac OS X’, os.arch: ‘x86_64’, os.version: ‘10.13.4’, java.version: ‘1.8.0_121’
Driver info: io.appium.java_client.ios.IOSDriver
Capabilities [{app= , networkConnectionEnabled=false, xcodeOrgId=, bundleId=, databaseEnabled=false, connectHardwareKeyboard=true, deviceName=iPhone, fullReset=true, xcodeSigningId=iPhone Developer, platform=MAC, shouldUseSingletonTestManager=false, maxTypingFrequency=10, sendKeyStrategy=oneByOne, newCommandTimeout=300, platformVersion=10.2.1, webStorageEnabled=false, locationContextEnabled=false, automationName=XCUITest, useNewWDA=true, browserName=, takesScreenshot=true, javascriptEnabled=true, udid=23917cdde7ce13cc3b9c94f4c190139db2e0a7c1, platformName=MAC}]
Session ID: e4565aff-f0c9-4a82-b60b-3291665c6638

Appium has a tendency to search for an element before the screen is rendered properly. If you’ve just opened a new screen and need to search for an element, wrap the search in an implicit wait so that it will poll for the element over a certain amount of time rather than just failing on the initial search:

More info here:

Used wait, still not working with appium desktop 1.8.2 and appium server 1.9.1 (Mojave mac, Xcode 10.1) iPhone 7 plus - 11.3 simulator

OP worked in Appium Desktop but not in Server. Since you have a different problem you should create a new thread.