Android enter button on softkeyboard does not work

I used the driver.SendkeyEvent(66); in java and appium does not show any error but emulator does not click on enter button on software keyboard. I try all methods but it does not work. I am using the appium And UI Automator Viewer does not display the soft keyboard buttons properties. And when i enter the adb shell input keyevent 66 on command prompt, my emulator does not press the enter button. I did not search any solution for this problem. It is the appium error or android adb error. What will be the solution for this error.

If you can’t send the enter button through “input keyevent 66”, then the problem is not related to Appium. It could be your emulator, or it could be that your app does not accept enter as an input for that button.

I am having the same issue. I have tried everything (66, 84, 86, 160) with or without 16 metastate option. With hardware emulator enabled or not… I think it may be to do with the app listening for IME_ACTION_DONE. Is there no way to send this via Appium?

Do you have any news here? Have you solved your problem?
I am facing the same issue and I am interested in knowing the solution please