ANDROID_HOME is set but does not exist on the file system

I am in the process of setting up Appium.

When I run the Appium-Doctor tool, I get the message ANDROID_HOME is set but does not exist on the file system at “/Users//Library/Android/sdk”.

I believe I have the ANDROID_HOME path variable set correctly, because when I run “echo $ANDROID_HOME” I get “$/Users//Library/Android/sdk”.

And when I go to the SDK Manager in Android Studio, it tells me that my SDK file path is indeed “/Users//Library/Android/sdk”.

What am I doing wrong?

I solved my own problem. Adding the answer here for others who might encounter it:

my PATH setting did not have the path in quotation marks. I had this:

export ANDROID_HOME=$/Users//Library/Android/sdk

instead of this:

export export ANDROID_HOME=$"/Users//Library/Android/sdk"


I don’t believe you need or want the ‘$’ character in there at all. My bash_profile has ANDROID_HOME defined as follows:

export ANDROID_SDK_ROOT=$HOME/android_sdk_ndk/sdk

Given you path and assuming you want ANDROID_SDK_ROOT defined, I’d expect to see this:

export ANDROID_SDK_ROOT=/Users//Library/Android/sdk

Alternatively, if you don’t want your sdk root set up, just this:

export ANDROID_HOME=/Users//Library/Android/sdk