Android native browser run failed through Did not get session redirect from Chromedriver

I tried to run Native Browser on Android 4.4. Apllication is run, but it stucked after.
Note: everything fine with capabilities.setCapability(“browserName”, “Chrome”), but I want to launch native browser.

My capabilities:
DesiredCapabilities capabilities = new DesiredCapabilities();
capabilities.setCapability(“browserName”, “Browser”);
capabilities.setCapability(“platformName”, “Android”);
capabilities.setCapability(“deviceName”,“My device”);
capabilities.setCapability(“platformVersion”, “4.4”);

Stack trace of appium:
info: [debug] [CHROMEDRIVER] Starting ChromeDriver (v2.10.267521) on port 9515
Only local connections are allowed.
info: [debug] Making http request with opts: {“url”:“
info: [debug] [CHROMEDRIVER STDERR] [0.008][SEVERE]: Could not bind socket to 12
info: [debug] [CHROMEDRIVER] Port not available. Exiting…
info: [debug] Chromedriver exited with code 1
info: [debug] Getting connected devices…
info: [debug] executing: “c:\Users\maxymkr\AppData\Local\Android\android-sdk\pla
tform-tools\adb.exe” -s 4df7eba26c84300d devices
info: [debug] 1 device(s) connected
info: [debug] executing: “c:\Users\maxymkr\AppData\Local\Android\android-sdk\platform-tools\adb.exe” -s 4df7eba26c84300d shell “am force-stop”
info: [debug] Stopping logcat capture
info: [debug] Logcat terminated with code null, signal SIGTERM
info: [debug] Cleaning up appium session
error: Chromedriver create session did not work. Status was 200 and body was {“sessionId”:“ca8c519a79d5ed140bbfc153bdd8ec3f”,“status”:100,“value”:{“message”:“chrome not reachable\n (Driver info: chromedriver=2.10.267521,platform=Windows NT 6.1 SP1 x86_64)”}}
info: [debug] Cleaning up appium session
error: Failed to start an Appium session, err was: Error: Did not get session redirect from Chromedriver
info: [debug] Error: Did not get session redirect from Chromedriver
at null. (d:\Job\appium git\appium\lib\devices\android\chromedriver.js:220:12)
at Request._callback (d:\Job\appium git\appium\lib\devices\common.js:116:5)
at Request.self.callback (d:\Job\appium git\appium\node_modules\request\request.js:121:22)
at Request.emit (events.js:98:17)
at Request. (d:\Job\appium git\appium\node_modules\request\request.js:985:14)
at Request.emit (events.js:117:20)
at IncomingMessage. (d:\Job\appium git\appium\node_modules\request\request.js:936:12)
at IncomingMessage.emit (events.js:117:20)
at _stream_readable.js:929:16
at process._tickDomainCallback (node.js:463:13)
info: [debug] Responding to client with error: {“status”:33,“value”:{“message”:“A new session could not be created. (Original error: Did not get session redirect from Chromedriver)”,“origValue”:“Did not get session redirect from Chromedriver”},“sessionId”:null}

Guys, any ideas hwo to solve this?

Have you been able to solve this issue?? I am also struck with the same. I have tried the same on real & emulator both, but no success.

Anyone please? I have been facing the same issue

restart the device.
Go to task manager - ctrl+alt+delete, go to processes, ensure there is no chromedriver.exe running.

Hi any one has overcome the above issue. I have been facing the same issue. Thanks.

To resolve this issue please update the chromedriver which comes with Appium. You can find this under /build/chromedriver/ and replace this with latest one 2.15.

I don’t think it’s related to Chromdriver version. This issue was reproduced only on Samsung devices, like Note2, S3, Tab 3.10. As other devices haven’t faced such issue. Also, we have the problem with S4, S5, Note3, Tab 4.10 - but it fixed after Android update.

I have seen such error multiple times and it was observed that chromedriver version is not compatible with the version of the browser. lets say you are trying to automate Chrome/native version 39 with chrome driver 2_15. This will not work. You have to use chrome v 40 for it to work with chromedriver 2_15. You have to give a try and checkout.