Android webdriverio Unable to interact with elements

I have successful iOS tests running, now trying tests on Android using similar methods. Using webdriverio in JS, I’ve added uiautomator2 as an automationName.

My issue is I can’t interact with elements…element("").click() is not working. When I run this through the desktop client and use the record function, it comes back suggesting: .element(“”).click() but when I use this I get a “Locator Strategy ‘css selector’ is not supported for this session” as the tilde (~) is dropped.

I’ve also tried:
let skip = ‘new UiSelector().resourceId(“”)’
and then .click(skip)

But get the same error.

I finally tried a suggested:

But get a reference error as it doesn’t like “By” (I guess because I am not using Selendroid due to it being deprecated)

Any ideas?

Bump, this must be a pretty basic issue that I’m doing wrong

can anyone update on above issue even am Facing same with Webdriver-IO

Have you resolved this? I’m experiencing the same issue

I’m facing same issue