[Answered: YES] Is iOS 17 Currently Supported?

I recently upgraded my XCode, MacOS and simulators to be able to test on iOS17. When trying to start a test from Appium I get an error saying WebDriverAgentRunner-Runner quit unexpectedly. A more detailed report is at the bottom of this post.

I have got the latest version of WebDriverAgent (5.83). I can build WebDriverAgent in XCode and can run the IntegrationApp on the Simulator. But when I try to run my app through appium inspector I get the error although WebDriverAgent is installed on the device.

I’m using the following capabilities to launch:

  "platformName": "iOS",
  "appium:deviceName": "iPhone 14 Pro",
  "appium:platformVersion": "17.0",
  "appium:bundleId": "com.me.myapp.debug",
  "appium:automationName": "XCUITest",
  "appium:udid": "518E855B-637B-4084-9295-74B11DDFC420",
  "appium:processArguments": "{\"args\":[\"-env=localhost\"]}"

Has anyone else had this issue or can point me in the right direction to solve it? A more detailed error report is below:

Translated Report (Full Report Below)

Incident Identifier: 34D04B07-2B9E-4E8D-9ED7-0C58157FAFD8
CrashReporter Key: B613B4B7-0256-7A97-9285-A991D12B6B15
Hardware Model: MacBookPro16,1
Process: WebDriverAgentRunner-Runner [34095]
Path: /Users/USER/Library/Developer/CoreSimulator/Devices/518E855B-637B-4084-9295-74B11DDFC420/data/Containers/Bundle/Application/3AF2563E-3F84-4585-BC36-E3CBFFB84B74/WebDriverAgentRunner-Runner.app/WebDriverAgentRunner-Runner
Identifier: com.facebook.WebDriverAgentRunner.xctrunner
Version: 1.0 (1)
Code Type: X86-64 (Native)
Role: Foreground
Parent Process: launchd_sim [31562]
Coalition: com.apple.CoreSimulator.SimDevice.518E855B-637B-4084-9295-74B11DDFC420 [5713]
Responsible Process: SimulatorTrampoline [2018]

Date/Time: 2023-09-07 12:36:44.8803 +1000
Launch Time: 2023-09-07 12:36:43.0205 +1000
OS Version: macOS 13.5.1 (22G90)
Release Type: User
Report Version: 104

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Termination Reason: SIGNAL 6 Abort trap: 6
Terminating Process: WebDriverAgentRunner-Runner [34095]

I changed your title to make what you are asking a little clearer. I’m sorry I don’t have an answer for you.

1 Like

Thank you. I have solved this now. User error. I had downloaded and build the latest web driver agent but the agent contained inside the xcuitest driver was still old. Once I updated the driver it worked.

1 Like

Thank you for sharing the solution.

Hi, I am getting the same issue, when manually trying to launch Webdriver agent (V5.15.6) from any iOS 17 device (Physical or Simulator) which webdriver version did you use?

HI @iparry7979! how do you updated the driver inside xcuitest? can you help me please? thx!

If you are using appium 2 type the following in a command propmpt:

appium driver update xcuitest

1 Like

Do you know how to keep WDA running after disconnecting the iPhone from MacBook? I can’t get it to run unless it is connected via USB or on the same network.