Appium 1.11.0beta3 take to long to initialize the app

Appium take about 30 sec to initialize the app

Do you have the full log?

Please find it here:

Can you please try if works for you? contains more details on how to run Appium from source

@Zuzeac Any success?

Hi @mykola-mokhnach , just did the test and I do not see any differences from the latest appium code and beta3.

latest code logs:
beta3 code logs:

I’m still seeing " Waiting up to 30000ms for UiAutomator2 to be online…"
Maybe it’s something from my setup ( though I tried on different devices) and it’s not a real problem with appium or uiAutomator2.

Hi @mykola-mokhnach,
After I run over night the test suite I observe that it took too much time to execute than usual.
It seems that I get this waiting for 30 sec between all my tests when using the 1.11.0-beta3.

I cross checked with 1.10.1 version and there it only take about 10 second between tests.
Just checked with the latest appium code and it’s the same.

Should I open an issue on github page?
I will use 1.10.1 v on my Jenkins machine and beta version on local until we have a fix here.