Appium 1.3.1 and Selendroid issues

Hi There.
I’ve been attempting to run my app on 4.0 using selendroid.
The app works fine on 4.4.

Here are my steps:

  1. Running appium from source as of 2014-11-11 master.
  2. Used specifically: ‘’’ node . --selendroid-port 8080 ‘’’
  3. Used the following Desired capabilities:
platformName = "Android"
platformVersion = "4.0"
deviceName = "Selendroid"
automationName = "Selendroid"
app = "./apps/android-learn-debug.apk"
appPackage = ""
appActivity = ""
  1. I start the test, the app initially launches, then I get an execution expired (Timeout::Error). Specifically appium’s log states:
info: [debug] Responding to client with error: {"status":7,"value":{"message":"An element could not be located on the page using the given search parameters.","origValue":"Element was not found.\nio.selendroid.exceptions.NoSuchElementException: Element was not found.\n\tat io.selendroid.server.handler.FindElement.handle(\n\tat io.selendroid.server.AndroidServlet.handleRequest(\n\tat io.selendroid.server.BaseServlet.handleHttpRequest(\n\tat io.selendroid.server.http.ServerHandler.channelRead(\n\tat\n\tat\n\tat io.netty.handler.codec.MessageToMessageDecoder.channelRead(\n\tat\n\tat\n\tat io.netty.handler.codec.ByteToMessageDecoder.channelRead(\n\tat\n\tat\n\tat\n\tat\n\tat$\n\tat\n\tat\n\tat\n\tat\n\tat io.netty.util.concurrent.SingleThreadEventExecutor$\n\tat io.netty.util.concurrent.DefaultThreadFactory$\n\tat\n"},"sessionId":"f3efe001-cc30-8fc1-1273-9082c130e3b2"}
  1. Here is the ADB of our app under test.
11-12 22:37:27.010    5048-5082/ I/System﹕ kill failed: ESRCH (No such process)
            at Method)
            at java.lang.ProcessManager$ProcessImpl.destroy(
            at io.netty.util.internal.PlatformDependent.isRoot0(
            at io.netty.util.internal.PlatformDependent.<clinit>(
            at io.netty.util.Signal.<clinit>(
            at io.netty.util.concurrent.DefaultPromise.<clinit>(
            at io.netty.util.concurrent.MultithreadEventExecutorGroup.<init>(
            at io.selendroid.server.http.HttpServer$

Then, this is repeating in my ADB ad nauseum.

11-12 22:37:27.445    5048-5091/ W/ResourceType﹕ No known package when getting name for resource number 0xffffffff
  1. NOTE: My AndroidManifest.xml does indeed have this permission:

Any additional help most welcome. Let me know if this should go to github.
I also saw this, but not sure that it was the same:

Thanks in advance!

Hi Eric! Your error is not related to the issue that I posted, where the app doesn’t launch when using Selendroid. I’m pretty sure your error is that your test isn’t able to find an element – you can see this in the Appium log:

Element was not found.
io.selendroid.exceptions.NoSuchElementException: Element was not found

If you look at the lines in the log above this error, you should find which element the test tried to find that resulted in the Timeout::Error. It may be related to the different ways to find an element using Selendroid vs uiautomator. For example, you must use the entire id for uiautomator –"") – vs just"login_button") for Selendroid.

Let me know if this isn’t the case and I’ll try to help further :slight_smile:

Hi Ling
Thanks so much for the post!
Totally makes sense
I’ll let you know if I have any further questions

I am also getting same error.

I have used
WebElement inputField = driver.findElement(“io.selendroid.testapp:id/my_text_field”));

but still getting same error.

Please help.