Appium 1.4.11 Released

Hello fellow Appium users,

We have released Appium 1.4.11.

Changes from 1.4.10

  • fix for iOS simulator selector for Xcode 7
  • fix for selecting default device for iOS9

You can track dot-app release issue here and dot-exe release issue here.


1 Like

hi @moizjv,

Do you have any plan to enable instruments-without-delay for Xcode 7? Currently I have a test suite that runs for almost 8 hour to finish. I can imagine without instruments-without-delay option, that suite will runs for days :frowning:


Why nobody want to build a dmg file?
1.4.8 is the latest version for download.

hi @tbao,

Yes we want to research that option. I have not been able to take time for that. Though for xcode 7 you might have to do it yourself, as old way of passing arguments does not work.

If you can make this work, let me know or add it to docs of appium, would help lot of people.


Hi I would just like to say it would be great if we could get a fix for the instruments-without-delay flag in Xcode 7 as Appium is extremely slow without it. Without a way around the 1 second delay it is very difficult to use Appium for testing a whole app, especially at an enterprise level.

@mweiss88 try using xcode 7.1 beta, not confirmed but looks like it is working with 7.1.

Thanks I’ll try this probably tomorrow and let you know if it’s working for certain or not

I tried this but it cannot find the iOS SDK Version

Forgot, I needed to update to Appium 1.4.13, trying again

Nope, even with 1.4.13 I still get the same error.

@moizjv o i tried using instruments-without-delay using appium 4.1.11 on xcode 7.1 Beta2 and it is much slower than using xcode 6 for the same version of appium and same tests.

ok I am going to investigate this next week. I will keep you updated on this

@mweiss88 it’s because instruments-without-delay is turned off for xcode 7.1. I have twist the appium source code a bit to turn it on for xcode 7, and do as:
Currently it’s the only workaround that I know for this

@tbao thanks, I’ll give that a try when I get the chance (will be a few days). Obviously a permanent fix in appium would be ideal but thanks for the work around!

@tbao can you share how you got it working?

@moizjv Maybe you got me wrong because all I did is just follow this: I just modified the plist and it works.
Hopefully you can find better solution for this instead of modifying the plist

Hi @tbao I also have problem with it.
It is clear that environment variable should be adde to plist file.

But how to do it step by step?
Could you explain it more extendedly?


@Degard Here are the steps that I did:

  1. Checkout this project: first. Make sure you can open it by Xcode and build it successfully.

  2. Back up this file: ./Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/Developer/Library/LaunchDaemons/ ( I assume your Xcode is installed in the same directory of mine, otherwise you can do a search from Xcode directory with file name “”)

  3. Open that file and add this key - dict:
    <key>EnvironmentVariables</key> <dict> <key>DYLD_INSERT_LIBRARIES</key> <string>/Users/tbao/Developer/tools/appium/instruments-without-delay/build/DTMobileISShim.dylib</string> <key>LIB_PATH</key> <string>/Users/tbao/Developer/tools/appium/instruments-without-delay/build</string </dict>

Note: You have to change the values for the two keys DYLD_INSERT_LIBRARIES, LIB_PATH according to your checked out instruments-without-delay project.

Now try to run appium again and see if it works. To be frankly, how the author of this project solves the problem is still a mystery to me but at least it works for me. Let me know if you have any problem and I’ll try to get back to you when I have time

@tbao Thank you, It works for me now. :smiley: