Appium 1.4.16 released

We are happy to announce release of 1.4.16, this fixes important webview issues with iOS 9.2.



  • fix for safari and webview issues for 9.2

Went to download but it still shows 1.4.13. is there any other place to get the new version?

its still not available as a download but you can still have this version from the source

I realize is a separate physical project from Appium. However, is often new users first experience and it typically lags weeks (and weeks) behind Appium versions. It’s still stuck on 1.4.13 and with broken symlinks last I checked that makes it unusable without manual fixing by the user.

Overall it often presents a poor Appium experience. Who do we lobby to have the Appium team consider absorbing so it can be as up-to-date as possible?

1 Like

@Christopher_Graham, I would not say that this approach leads to poor user experience. My arguments here would be:

  • Like you said, is often for new users who can get familiar with its flow and concept. Most of them (I would take risk to say - all of them) do not need GUI version compatible with newest npm version. Before you disagree please read next points

  • From my observation, since version 1.3.5 when some bigger release comes out, week or two later gui app is also available. No risk that user who used GUI version will miss some important features (for example new X.0 iOS support).

  • At the end we must also remember that this is free open source tool. We are not paying for that so there should be full understanding that resources are limited. So if it comes to me I won’t join to your request. I would rather Appium developers to focus on more important things like new iOS driver implementation (due to UIAutomation deprecation by Apple).I’m not testing Androind but I’m sure our community would find much more important targets for further development.

  • To be honest at the beginning I was also using only GUI. Since I start using npm I use it only as GUI inspector to define locators for my tests. For this function newest version is not required.

  • It may be my personal opinion but i don’t understand why so many appium users are afraid to try npm version. It is so much easier to manage and automate. For me perfect scenario for future would be GUI appium inspector with basics server configs plus npm vesion with full set of features

It is only my opinion. If i missing something or someone also really needs gui so much, feel free to discuss :wink:



When I installed appium 1.4.16 , I see an npm error:
npm ERR! missing: bplist-parser@~0.0.6, required by [email protected]

Appium still seems to work correctly. I didn’t see this error on previous versions of Appium.

Anyone else see this?

@smccarthy today I’ve upgraded appium to version 1.4.16 and saw same error as well.

I googled but didn’t find fix for same ?

Can you please share if you found fix for this or we can ignore this error ?


Hi @VikramSilk , I have not heard anything about this error. I haven’t seen any issues when I run my mobile tests locally, so I don’t think it is affecting anything.

@smccarthy Thanks for quick clarification.


Hi Sunny,
How do I install appium 1.4.16. Currently i have 1.4.13 on MAC. And no dmg file available for 1.4.16.
kindly help me out. thanks

@saranya_natarajan it doesn’t exist. The .app hasn’t been updated in 6 months. You can install the server via command line and then specify the newer server version in the .app via Developer Settings but that seems to be at least partially problematic with the latest Appium 1.5 which is the latest server version as you cannot physically launch the server from the .app and have to set breakpoints in your test code to pause the test so you can then launch the Inspector. It’s not ideal, but eventually you can get a usable process.

Ok @Christopher_Graham. Thanks, i’ll try to install appium 1.5 and check