Appium 1.6.0 Released


#1

The Appium team has just released Appium 1.6.0. This marks a huge milestone for the project in terms of support for new platforms. The introduction of significant new functionality meant that we wanted to take time to prepare this release, and indeed we had various beta versions of 1.6 out for the last month.

XCUITest

Most importantly for existing Appium users, we have added support for Appium to target Apple’s new XCUITest framework, which includes support for iOS 10 / Xcode 8. The XCUITest framework provided by Apple was previously only available through the Xcode toolchain. Now, you can take advantage of Appium’s WebDriver architecture while staying up to date with the latest Apple automation technology. And a good thing too: with iOS 10 / Xcode 8, Apple has removed the older UIAutomation framework, which powered Appium’s iOS automation up to this point. When you specify a platformVersion of 10 or higher, Appium will automatically use the XCUITest automation backend. If you would like to run the XCUITest automation backend with iOS 9.3, simply specify automationName: XCUITest in your desired capabilities. Given that there are some inevitable and substantial differences between XCUITest and the technology that Appium targeted in the past for iOS automation, we wrote up a migration doc to help with the transition: https://github.com/appium/appium/blob/master/docs/en/advanced-concepts/migrating-to-xcuitest.md. We spent a lot of time testing our XCUITest support, but seeing that it is brand new, we expect to come across further differences or minor issues. Please raise an issue on Appium’s GitHub repository if you have any problems!

Windows

Secondly, the Appium team is extremely proud to release the first iteration of our integration with Microsoft’s WinAppDriver, a Windows app automation technology designed from the ground up to work with Appium. Getting started with Appium’s Windows support is dead simple; check out our instructions at: https://github.com/appium/appium/blob/master/docs/en/writing-running-appium/windows-app-testing.md. We’re really excited to see what you do with it, and stay tuned for future expansion of Windows support into new areas!

UiAutomator 2

Appium 1.6 also ships with early beta support of an upgrade to Appium’s Android support. Up till now, Appium has targeted Google’s UiAutomator framework as the primary way of automating native Android apps. UiAutomator has a number of limitations, and Google has tried to address some of these in their follow-up UiAutomator 2, which (much like XCUITest) has a very different architecture and required a significant effort to support. Thanks to a dedicated team of volunteers, you can now specify automationName: uiautomator2 in your desired capabilities and try out the new driver. For more info, check out the wiki article here: https://github.com/appium/appium-uiautomator2-server/wiki

Youi.tv

Finally, the folks behind You.i Engine have released an Appium driver for automating apps built with their framework. This is an exciting development for Appium and we’re glad to have various platform vendors choosing to work with us to provide automation for developers building on their platform! Several new capabilities are required to automate your Youi-based application. See details here: https://github.com/YOU-i-Labs/appium-youiengine-driver#usage

We hope you are able to take advantage of all the new support released as part of Appium 1.6.0. For more details about the release, you can always check out our CHANGELOG and release notes: https://github.com/appium/appium/releases/tag/v1.6.0

npm install -g appium and happy testing!


Unable to launch apk using appium. error: Unhandled error: Error: connect ECONNREFUSED
#2

This topic is now a banner. It will appear at the top of every page until it is dismissed by the user.


#3

Hey, so I’m getting odd errors for this. below are my errors in screen shots.
First step was just wiping out appium, and using “sudo npm install -g appium”

  • that seemed to go just fine, so i set up a quick test to basically just boot the sim up and driver was activated correctly, but error’d out with this error.

here is a VERY shortened log.
Error_out_log.log (8.4 KB)

Noticed these errors out of the log.
[Xcode]
Testing failed:
Mkdir: Modules: Permission denied

[Xcode] ./Scripts/generate_modules.sh: line 15: Modules/module.modulemap: No such file or directory
** TEST FAILED **

The following build commands failed:
PhaseScriptExecution Generate\ modules /Users/information/Library/Developer/Xcode/DerivedData/WebDriverAgent-brdadhpuduowllgivnnvuygpwhzy/Build/Intermediates/WebDriverAgent.build/Debug-iphonesimulator/WebDriverAgentLib.build/Script-AD35D0281CF1B37A00870A75.sh
(1 failure)

i read somewhere to see what happens when i run bootstrap.sh in the Scripts folder in the WebDriverAgent dir. there is the output log.
Error_out_log.log (8.4 KB)

Version of Xcode is 8
Npm: 3.10.3
Node: 6.7.0

So somehow i got the 1.6 beta2 working for a short wile then i upgraded to beta3 and couldn’t revert back and could not ever get 1.6 working again. Please help me.
Tried wiping out all of npm, and nodes starting from scratch many times. What versions of everything are other people using for this. AND if anyone knows of a nice easy way to clean out all of npm and node and appium off of a computer let me know due to the annoying way i know of is ti manually delete files.

Thanks everyone!

UPDATE:

wow sometimes just writing this out and re looking for the 100th times jogs the memory, so i had to go in and enable Scripts folder in the WebDriverAgent to allow read and write from all users, which for me nobody, staff, and everyone. ill leave this all here incase anyone else runs into this problem.


#4

Thanks to the Appium team for this very important milestone. Good job guys!

Would like to get some clarity with the release of Appium 1.6.

Currrently, we’re using Appium 1.4.16 supporting iOS devices until 9.3.5 with XCode 7.x.x and also Android and so far all is good. We would like to also support devices running iOS 10 while also maintaining backward compatibility. If my understanding is correct, to use Appium 1.6, we need to have XCode 8 on the target machine and NOT Xode 7.x.x. Please correct me if I’m wrong.

In other words, what should we do at the setup level in supporting iOS 8.x, 9.x and the new iOS 10.x on any single laptop?

Please advise.


#5

Thanks - Important milestone for Appium community.


#6

Anybody can help me on this please?

Thanks.


#7

Wow Impressive work guys


#8

Thanks Appium team…Good job


#9

Can some one please walk through the exact steps of how we need to install appium 1.6?


#10

I can successfully able to launch my simulator, but before completing simulator bootstrap, appium trying to get install the app on simulator thats why I got below error (thats what I understood with below error log) please help me to get out below error. Thanks Shabana:

PS: I try to follow steps mentioned in https://github.com/appium/appium/issues/6853

[Appium] Welcome to Appium v1.6.0 (REV f653cb8340de3c9acd1ddfb75c1a8c8f3195834a)
[Appium] Appium REST http interface listener started on 0.0.0.0:4723
[HTTP] --> POST /wd/hub/session {“desiredCapabilities”:{“app”:"/Users/f2849/Desktop/ShineDev2016-10-14/ShineDev.ipa",“sendKeyStrategy”:“grouped”,“newCommandTimeout”:“9000”,“platformVersion”:“10.0”,“automationName”:“XCUITest”,“platformName”:“iOS”,“deviceName”:“iPhone 5”}}
[MJSONWP] Calling AppiumDriver.createSession() with args: [{“app”:"/Users/f2849/Deskt…
[Appium] Creating new XCUITestDriver session
[Appium] Capabilities:
[Appium] app: ‘/Users/f2849/Desktop/ShineDev2016-10-14/ShineDev.ipa’
[Appium] sendKeyStrategy: ‘grouped’
[Appium] newCommandTimeout: ‘9000’
[Appium] platformVersion: ‘10.0’
[Appium] automationName: ‘XCUITest’
[Appium] platformName: ‘iOS’
[Appium] deviceName: ‘iPhone 5’
[debug] [XCUITest] XCUITestDriver version: 2.0.26
[BaseDriver] Capability ‘newCommandTimeout’ changed from string (‘9000’) to integer (9000). This may cause unexpected behavior
[BaseDriver] Session created with session id: c4360084-df3d-4d30-9bcf-6315d3843148
[debug] [XCUITest] Xcode version set to ‘8.0’
[debug] [XCUITest] iOS SDK Version set to ‘10.0’
[iOSSim] Constructing iOS simulator for Xcode version 8.0 with udid ‘4FE61E16-B812-4E15-9A7B-9DC062CB10F3’
[XCUITest] Determining device to run tests on: udid: ‘4FE61E16-B812-4E15-9A7B-9DC062CB10F3’, real device: false
[BaseDriver] Using local app ‘/Users/f2849/Desktop/ShineDev2016-10-14/ShineDev.ipa’
[debug] [BaseDriver] Copying local zip to tmp dir
[debug] [BaseDriver] Unzipping /var/folders/st/41dk4fnd10518617jytfvjhh0000gq/T/2016919-39298-1jisrrs.ranzlac3di/appium-app.zip
[debug] [BaseDriver] Testing zip archive: /var/folders/st/41dk4fnd10518617jytfvjhh0000gq/T/2016919-39298-1jisrrs.ranzlac3di/appium-app.zip
[BaseDriver] Unzipped local app to ‘/var/folders/st/41dk4fnd10518617jytfvjhh0000gq/T/2016919-39298-1jisrrs.ranzlac3di/Payload/ShineDev.app’
[debug] [XCUITest] Checking whether app is actually present
[debug] [ios-app-utils] Getting bundle ID from app
[debug] [iOSLog] Starting iOS 10.0 simulator log capture
[debug] [iOSLog] System log path: /Users/f2849/Library/Logs/CoreSimulator/4FE61E16-B812-4E15-9A7B-9DC062CB10F3/system.log
[XCUITest] Setting up simulator
[debug] [iOS] No reason to set locale
[debug] [iOS] No iOS / app preferences to set
[XCUITest] Simulator with udid ‘4FE61E16-B812-4E15-9A7B-9DC062CB10F3’ not booted. Booting up now
[debug] [iOSSim] Killing all iOS Simulators
[iOSSim] Starting simulator with command: open /Users/f2849/Documents/NewVolume/Softwares/Xcode.app/Contents/Developer/Applications/Simulator.app --args -CurrentDeviceUDID 4FE61E16-B812-4E15-9A7B-9DC062CB10F3
[iOSSim] Tailing simulator logs until we encounter the string “SMS Plugin initialized”
[iOSSim] We will time out after 60000ms
[debug] [iOSSim] Simulator startup timed out. Continuing anyway.
[debug] [iOSSim] Waiting an extra 10000ms for the simulator to really finish booting
[debug] [iOSSim] Done waiting extra time for simulator
[iOSSim] Simulator booted in 70411ms
[debug] [XCUITest] Installing app ‘/var/folders/st/41dk4fnd10518617jytfvjhh0000gq/T/2016919-39298-1jisrrs.ranzlac3di/Payload/ShineDev.app’ on device
[XCUITest] Using default agent: /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgent.xcodeproj
[XCUITest] Using default bootstrap: /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent
[XCUITest] Launching WebDriverAgent on the device
[XCUITest] Carthage not found. Install using brew install carthage
[debug] [XCUITest] Running WebDriverAgent bootstrap script to install dependencies
[XCUITest] Error: Command ‘/bin/bash Scripts/bootstrap.sh -d’ exited with code 1
at ChildProcess. (lib/teen_process.js:66:19)
at emitTwo (events.js:106:13)
at ChildProcess.emit (events.js:191:7)
at maybeClose (internal/child_process.js:852:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:215:5)
{ Error: Command ‘/bin/bash Scripts/bootstrap.sh -d’ exited with code 1
at ChildProcess. (lib/teen_process.js:66:19)
at emitTwo (events.js:106:13)
at ChildProcess.emit (events.js:191:7)
at maybeClose (internal/child_process.js:852:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:215:5)
stdout: ‘\u001b[1mFetching dependencies\nPlease make sure that you have Carthage installed (https://github.com/Carthage/Carthage)\nNote: We are expecting that carthage installed in /usr/local/bin/\n’,
stderr: ‘’,
code: 1 }
[debug] [XCUITest] Running iOS simulator reset flow
[debug] [XCUITest] Shutting down simulator
[debug] [iOSSim] Killing all iOS Simulators
[debug] [XCUITest] Cleaning simulator state.
[debug] [iOSSim] Cleaning app data files for ‘ShineDev.app’, ‘com.htmedia.shine’
[debug] [iOSSim] Building bundle path map
[debug] [iOSSim] Building bundle path map
[debug] [iOSSim] Deleting directory: ‘/Users/f2849/Library/Developer/CoreSimulator/Devices/4FE61E16-B812-4E15-9A7B-9DC062CB10F3/data/Containers/Data/Application/A826EB9B-8BAE-42F4-B850-B5606517A9CA’
[debug] [iOSSim] Deleting directory: ‘/Users/f2849/Library/Developer/CoreSimulator/Devices/4FE61E16-B812-4E15-9A7B-9DC062CB10F3/data/Containers/Bundle/Application/E5CACB2F-9AC1-4724-A80C-4629A376A9F3’
[debug] [iOSSim] Deleting file: ‘/Users/f2849/Library/Developer/CoreSimulator/Devices/Library/Preferences/com.htmedia.shine.plist’
[debug] [iOSSim] Killing any simulator daemons for 4FE61E16-B812-4E15-9A7B-9DC062CB10F3
[iOSSim] Cleaning simulator 4FE61E16-B812-4E15-9A7B-9DC062CB10F3
[debug] [XCUITest] Resetting simulator
[debug] [XCUITest] Shutting down simulator
[debug] [iOSSim] Killing all iOS Simulators
[debug] [iOSLog] Stopping iOS log capture
[MJSONWP] Encountered internal error running command: Error: Command ‘/bin/bash Scripts/bootstrap.sh -d’ exited with code 1
at ChildProcess. (lib/teen_process.js:66:19)
at emitTwo (events.js:106:13)
at ChildProcess.emit (events.js:191:7)
at maybeClose (internal/child_process.js:852:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:215:5)
[HTTP] <-- POST /wd/hub/session 500 377205 ms - 199


#11

Hello,

Even I am able to launch the simulator successfully but getting an error as -

Error: listen EADDRINUSE 0.0.0.0:4723
at Object.exports._errnoException (util.js:890:11)
at exports._exceptionWithHostPort (util.js:913:20)
at Server.__dirname.Server.Server._listen2 (net.js:1230:14)
at listen (net.js:1266:10)
at net.js:1375:9
at _combinedTickCallback (internal/process/next_tick.js:77:11)
at process._tickCallback (internal/process/next_tick.js:98:9)

I am working with Xcode8 , ios10 and, automation_name = XCUITest. Please if anyone can help to automate the app further as Apple has completely removed the UIAutomation instrument, thus making it impossible for Appium to allow testing in the way it used to.


#12

Hi shabana-parveen,
Seems like you don’t have carthage installed. Please install by running:

brew install carthage


#13

on MAC,
download Node v6, LTS
in bash, type sudo npm install -g [email protected]
once its done, close
open new terminal type in appium


#14

Hi Folks, I wanted to know whether it would be possible to automate iOS App store search and get App info, i dont want to download any app, just want to perform search and get app info, could anyone provide their comments on this please


#15

hey can you please tell me from where u installed appium 1.6 beta version and how to install?
I tried to install appium 1.6 but getting the same error what you got…
Please let me know


#16

Hi, tried ur suggestion " brew install carthage ". still no luck, was getting same error as shabana-parveen. Hope to find the solution ASAP :slight_smile:


#17

Is there any way to download the latest beta without npm? I’m behind a proxy and can not bypass it…


#18

Hi,

can you give a hint when the Appium 1.6.0 with GUI will be release for MacOS?

Greets


#19

Will there be an ‘appium-1.6.0.dmg’ at https://bitbucket.org/appium/appium.app/downloads/ ?

Thanks


#20

Hi Folks, I am trying to use appium 1.6.0 with ios10 app build with Xcode 8. I and facing below issue. We have set signing certifcate and provisioning profile for WebdriverAgentRunner, as mentioned on Ios 10 with xcode 8 issue. still we facing same issue. Could anyone help in this?

[Appium] Welcome to Appium v1.6.0 (REV b134e1af00e0aa83f686e31c020c9b2b4ce53b18)
[Appium] Appium REST http interface listener started on 0.0.0.0:4723
[HTTP] --> POST /wd/hub/session {“desiredCapabilities”:{“deviceName”:“iPhone 6s”,“udid”:“cfc28f7a68b714e7f0e188bbb802e5316b7643cb”,“app”:"/Users/nagarro/Desktop/Melody_app/home-owner-app.app",“autoWebview”:“true”,“realDeviceLogger”:"/usr/local/lib/node_modules/deviceconsole/deviceconsole",“sendKeyStrategy”:“setValue”,“newCommandTimeout”:9000,“platformVersion”:“10.0”,“platformName”:“iOS”,“automationName”:“XCUITest”}}
[MJSONWP] Calling AppiumDriver.createSession() with args: [{“deviceName”:“iPhone 6s”,…
[Appium] Creating new XCUITestDriver session
[Appium] Capabilities:
[Appium] deviceName: ‘iPhone 6s’
[Appium] udid: ‘cfc28f7a68b714e7f0e188bbb802e5316b7643cb’
[Appium] app: ‘/Users/nagarro/Desktop/Melody_app/home-owner-app.app’
[Appium] autoWebview: ‘true’
[Appium] realDeviceLogger: ‘/usr/local/lib/node_modules/deviceconsole/deviceconsole’
[Appium] sendKeyStrategy: ‘setValue’
[Appium] newCommandTimeout: 9000
[Appium] platformVersion: ‘10.0’
[Appium] platformName: ‘iOS’
[Appium] automationName: ‘XCUITest’
[debug] [XCUITest] XCUITestDriver version: 2.0.26
[BaseDriver] Capability ‘autoWebview’ changed from string to boolean. This may cause unexpected behavior
[BaseDriver] Session created with session id: 2cdaa8f2-16dc-406d-bd8d-81a760089555
[debug] [XCUITest] Xcode version set to ‘8.0’
[debug] [XCUITest] iOS SDK Version set to ‘10.0’
[debug] [XCUITest] Available devices: cfc28f7a68b714e7f0e188bbb802e5316b7643cb
[debug] [XCUITest] Creating iDevice object with udid cfc28f7a68b714e7f0e188bbb802e5316b7643cb
[XCUITest] Determining device to run tests on: udid: ‘cfc28f7a68b714e7f0e188bbb802e5316b7643cb’, real device: true
[BaseDriver] Using local app ‘/Users/nagarro/Desktop/Melody_app/home-owner-app.app’
[debug] [XCUITest] Checking whether app is actually present
[debug] [ios-app-utils] Getting bundle ID from app
[debug] [iOSLog] Attempting iOS device log capture via libimobiledevice idevicesyslog
[debug] [iOSLog] Found idevicesyslog: ‘/usr/local/bin/idevicesyslog’
[XCUITest] Setting up real device
[debug] [XCUITest] Stdout from app isInstalled check: […] Waiting for iOS device to be connected
[…] Using iPhone 6s ‘iPhone 6s’ (cfc28f7a68b714e7f0e188bbb802e5316b7643cb).
true

[debug] [XCUITest] App is installed.
[debug] [XCUITest] Full reset not requested. No need to install.
[XCUITest] Using default agent: /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgent.xcodeproj
[XCUITest] Using default bootstrap: /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent
[XCUITest] Launching WebDriverAgent on the device
[debug] [XCUITest] Carthage found: /usr/local/bin/carthage
[debug] [XCUITest] Beginning test with command ‘/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/bin/run-xcodebuild.sh --project /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgent.xcodeproj --scheme WebDriverAgentRunner --destination id=cfc28f7a68b714e7f0e188bbb802e5316b7643cb’ in directory ‘/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent’
[XCUITest] Waiting for WebDriverAgent to start on device
[debug] [XCUITest] Log file for xcodebuild test: /var/root/Library/Developer/Xcode/DerivedData/WebDriverAgent-brdadhpuduowllgivnnvuygpwhzy/Logs/Test/34C92D99-1512-489E-8647-22220A2D7560/Session-WebDriverAgentRunner-2016-10-26_135756-gbtV3x.log
[Xcode] 2016-10-26 13:58:00.699 xcodebuild[6745:99493] Error Domain=IDETestOperationsObserverErrorDomain Code=3 “Test operation was canceled. If you believe this error represents a bug, please attach the log file at /var/root/Library/Developer/Xcode/DerivedData/WebDriverAgent-brdadhpuduowllgivnnvuygpwhzy/Logs/Test/34C92D99-1512-489E-8647-22220A2D7560/Session-WebDriverAgentRunner-2016-10-26_135756-gbtV3x.log” UserInfo={NSLocalizedDescription=Test operation was canceled. If you believe this error represents a bug, please attach the log file at /var/root/Library/Developer/Xcode/DerivedData/WebDriverAgent-brdadhpuduowllgivnnvuygpwhzy/Logs/Test/34C92D99-1512-489E-8647-22220A2D7560/Session-WebDriverAgentRunner-2016-10-26_135756-gbtV3x.log}

[Xcode]
Testing failed:
Signing for “WebDriverAgentRunner” requires a development team. Select a development team in the project editor.

[Xcode] Code signing is required for product type ‘UI Testing Bundle’ in SDK ‘iOS 10.0’
** TEST FAILED **

The following build commands failed:
Check dependencies
(1 failure)

[XCUITest] xcodebuild exited with code ‘65’ and signal ‘null’
[debug] [XCUITest] xcodebuild failure warrants retry. Retrying…
[XCUITest] Shutting down WebDriverAgent
[XCUITest] System log exited with code ‘null’
[XCUITest] Launching WebDriverAgent on the device
[debug] [XCUITest] Carthage found: /usr/local/bin/carthage
[debug] [XCUITest] Beginning test with command ‘/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/bin/run-xcodebuild.sh --project /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgent.xcodeproj --scheme WebDriverAgentRunner --destination id=cfc28f7a68b714e7f0e188bbb802e5316b7643cb’ in directory ‘/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent’
[XCUITest] Waiting for WebDriverAgent to start on device
[debug] [XCUITest] Log file for xcodebuild test: /var/root/Library/Developer/Xcode/DerivedData/WebDriverAgent-brdadhpuduowllgivnnvuygpwhzy/Logs/Test/5900F295-6525-49A8-9FAB-6D8F213287C6/Session-WebDriverAgentRunner-2016-10-26_135806-V8J7eI.log
[Xcode] 2016-10-26 13:58:10.684 xcodebuild[6982:99893] Error Domain=IDETestOperationsObserverErrorDomain Code=3 “Test operation was canceled. If you believe this error represents a bug, please attach the log file at /var/root/Library/Developer/Xcode/DerivedData/WebDriverAgent-brdadhpuduowllgivnnvuygpwhzy/Logs/Test/5900F295-6525-49A8-9FAB-6D8F213287C6/Session-WebDriverAgentRunner-2016-10-26_135806-V8J7eI.log” UserInfo={NSLocalizedDescription=Test operation was canceled. If you believe this error represents a bug, please attach the log file at /var/root/Library/Developer/Xcode/DerivedData/WebDriverAgent-brdadhpuduowllgivnnvuygpwhzy/Logs/Test/5900F295-6525-49A8-9FAB-6D8F213287C6/Session-WebDriverAgentRunner-2016-10-26_135806-V8J7eI.log}

[Xcode] Code signing is required for product type ‘UI Testing Bundle’ in SDK ‘iOS 10.0’

[Xcode]

[Xcode]
Testing failed:
Signing for “WebDriverAgentRunner” requires a development team. Select a development team in the project editor.
Code signing is required for product type ‘UI Testing Bundle’ in SDK ‘iOS 10.0’
** TEST FAILED **

The following build commands failed:
Check dependencies
(1 failure)

[XCUITest] xcodebuild exited with code ‘65’ and signal ‘null’
[XCUITest] Error: xcodebuild failed with code 65
at SubProcess. (lib/webdriveragent.js:294:25)
at emitTwo (events.js:87:13)
at SubProcess.emit (events.js:172:7)
at ChildProcess. (lib/teen_process.js:191:14)
at emitTwo (events.js:87:13)
at ChildProcess.emit (events.js:172:7)
at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
[Error: xcodebuild failed with code 65]
[debug] [XCUITest] Running ios real device reset flow
[debug] [XCUITest] Resetting simulator
[debug] [iOSLog] Stopping iOS log capture
[MJSONWP] Encountered internal error running command: Error: xcodebuild failed with code 65
at SubProcess. (lib/webdriveragent.js:294:25)
at emitTwo (events.js:87:13)
at SubProcess.emit (events.js:172:7)
at ChildProcess. (lib/teen_process.js:191:14)
at emitTwo (events.js:87:13)
at ChildProcess.emit (events.js:172:7)
at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
[HTTP] <-- POST /wd/hub/session 500 22337 ms - 167