Appium 15.1 doesn't clear the field in appium iOS

My iOS Ruby tests doesn’t clear the text in the login field since appium 15.1. Not sure why its not working. The alternate way tried is by using delete from the keypad, but its really slow. I have tried to control + a on the field to highlight the text field, but it doesn’t work. Any suggestion is highly appreciated.

@sai-poluri met same with one of WebView with native app. really do not want switch to WebView yet as we do not have much WebViews inside our app. to speed-up a bit i did long tap (selects word) and continue with delete_key :slight_smile:

Hi Sai, I made a thread about the same issue here: Clear elements is not working (and I think I made on the same day as you!).

I haven’t found any solutions yet, I’m also running Ruby tests in iOS. Mykola has been helping me, let’s hope we can find a solution to this.



The found an alternate way by holding and clicking the select all and then deleting the field. But not sure why its not working at first place. @OctavioN Glad I found some one who is working on the same tools.