Appium 6+ version Java client - Touch action doesn't work as expected in Android - Closed

I upgraded the java client version to 6 and modified the touch actions accordingly.
Tap doesn’t seem to work for android (both physical and emulator). IOS working as expected.
Android versions: 6.0, 7.0, 8.0 (Tried in all 3 versions)
Appium Server: 1.8.1
Java client: Tried with 6.1.0, 6.0.0, 6.0.0-BETA5, 6.0.0-BETA1 (all same result)

Different Touch actions for tap (tried all the below commands)

  1. new TouchAction<>(driver).tap(ElementOption.element(driver.findElement(thisBy)));
  2. new AndroidTouchAction(driver).tap(ElementOption.element(driver.findElement(thisBy)));
  3. new AndroidTouchAction(driver).tap(TapOptions.tapOptions().withElement(ElementOption.element(driver.findElement(thisBy))));
  4. new TouchAction<>(driver).tap(TapOptions.tapOptions().withElement(ElementOption.element(driver.findElement(thisBy))));

None of the above commands worked for tap in android. Appium doesn’t throw any error back - it shows successful but tap action doesn’t happen in UI.

Is anyone facing this issue ?
The command which I am trying - is it correct ?

I don’t see any bugs associated with it though (not sure whether this is a defect with appium java client)
Kindly suggest !

Sorry guys, silly me :wink: I missed to mention .release().perform() in the end.

new TouchAction<>(driver).tap(ElementOption.element(driver.findElement(thisBy))).release().perform() - It works charm !