Appium and Java Script


I am looking for some tutorial/ documentation for appium with java script.
Please let me know if anyone is aware about any information on the same.


Have you tried doing a google search? There are plenty of resources out there:"java%20script"%20tutorial

Thanks for sharing the search url. I tried doing the same. But majority of the results are covering either appium or appium-java.
only 2 or 3 have appium and node.js framework explained. But not in detail.

The second link on that search, Appium JavaScript Workshop, that has detailed examples and run commands didn’t help?

Yes, actually I cloned the same project and was working on that.
I wanted to run locally and set SAUCE=false. I have ipa for the iphone app. I have put it in my apps folder.
Ques : app.js : do I need to zip the ipa file?
caps.js : should I update the or add in the list of capabilities?

The ipa file is already a zip file, it’s just renamed to .ipa. You can test this by opening with an archive tool. <–keep in mind that the .ipa file is only for real devices. If you want to test on Simulator you’ll have to compile for Simulator and use a .app file.

For the capabilities, I for proof of concept you could probably get away with the defaults (unless they don’t work in your environment), but somewhere down the line you are going to want to customize this.

Thanks. I am able to do the setup and execute but getting error on Sauce lab credentials. I am trying to launch the test app on my device.
I have changed the capability to :
‘9.0.2’: {
browserName: ‘’,
appiumVersion: appiumVer,
platformName: ‘iOS’,
platformVersion: ‘9.0.2’,
deviceName: ‘iPhone 6s’,
app: undefined // will be set later

:javascript-workshop mguhe$ grunt test:ios:9.0.2
Running “env:9.0.2” (env) task

Running “simplemocha:ios” (simplemocha) task

Please configure your sauce credential:


Warning: Missing sauce credentials Use --force to continue.

Aborted due to warnings.

How do I run it on my local device?

Seems like it’s not reading ‘SAUCE=false’ properly. Are you running this in any kind of IDE?

Now its working fine. I could setup and launch my app. Thanks!!

1 Like

Yes Even am Looking For Java Script Appium