Appium app 1.2.2: port error message when port specified


I would like to inspect the application with the appium app. This worked before and I am quite sure that I did not change the settings. The app is installed on the phone (from the terminal appium, it also launches there) but I always get the error “Port must be greater than 0 and less than 65536” when trying to launch (for later inspecting) the app from the appium application.

App path: I set the path to the app (same which was installed from the appium terminal). I think I do not need this when the app is pre-installed, it does not work either way (with or without this param)
Package/ Launch activity and Wait for activity: specified
Launch Arguments: "-U deviceName -p 5108 -selendroid-port 5008 -> tried with and without specifying it, both promts the same error mentioned above
Platform Name: Android
Automation Nane: Selendroid (since the physical device is 4.0.3)

I do not understand the error message (since I set the ports in the arguments) and I am not sure wether its a bug in appium application 1.2.2 or I use wrong parameters.

OS X 10.9.5
Appium version (terminal) 1.2.3
Appium version App (used): 1.2.2
Physical device: 4.0.3

What port and IP address are you using for the Appium server??

In “Launch Device/ Arguents”, I use “-U LGOTMS327914d3 -p 5108 -selendroid-port 5008”

I remember I faced such error message before, I can’t remember how I got rid of it :frowning:
Try to explicitly add the IP Address of the server to your server configurations:


Hi Hassan! Thanks for your suggestion. Unfortunately, it did not work. I use the appium app only for the inspector and the command line for running tests itself. The problem seems to be Selendroid. When using a device > API 17 and making Appium as capa, it works. I am not sure if this is a new issue but I think that Selendroid faces more troubels currently.

Does anyone know how to run with appium app and selendroid?

If the problem seems to be with Selendroid, can you try removing that line and use the default selendroid port and see how it goes???


Yes, I also think that it is an Selendroid issue but seems to be related only to the appium app (which is in version 1.2.2 and the command line is 1.2.3, so maybe there is an issue as well).

Your suggestion did not work, I attach a screenshot so maybe there is something else odd. Thanks a lot, Christian

You should use the custom flags you are passing here,not where you are putting them.

Maybe it’s a problem with using the app after all, not the app iteslef :slight_smile:

Thanks, this worked (strange, I always used the other field but I should have used this one). THANKS A LOT