Appium "APP_PATH must be set" error

Im trying yo automate tests using selenium webdriver, rspec and appium
appium version: v1.3.4-beta1 (but i also tried 1.3.0 and it didnt worked too)
xcode version: 6.1 (the latest)

i try to run it using ios7.1 and iphone 5 simulator, it used to work a few weeks ago, but I dont know what is missing that it dont work now)


capabilities_ios = {
  'platformName' => 'iOS',
  'deviceName' => 'iPhone 5',
  'platformVersion' => '7.1',
  'app_path' => absolute_app_path_ios,
  'app' => absolute_app_path_ios
server_url = "" absolute_app_path_ios, driver: (Selenium::WebDriver.for(
:url => server_url,
:desired_capabilities => capabilities_ios))).start_driver

Appium.promote_appium_methods Object

when I try to run it, appium works as it should, the app starts, but i have the error on my test

/Users/julia/.rvm/gems/ruby-2.1.2/gems/appium_lib-0.24.1/lib/appium_lib/driver.rb:264:in `initialize': APP_PATH must be set. (RuntimeError)

part of appium log:

info: [debug] Device launched! Ready for commands
info: [debug] Setting command timeout to the default of 12000 secs
info: [debug] Appium session started with sessionId a220c01e-0a29-4e8d-bbdf-417db06ae5f0
info: <-- POST /wd/hub/session 303 22908.064 ms - 9 
info: --> GET /wd/hub/session/a220c01e-0a29-4e8d-bbdf-417db06ae5f0 {}
info: [debug] Responding to client with success: {"status":0,"value":{"webStorageEnabled":false,"locationContextEnabled":false,"browserName":"iOS","platform":"MAC","javascriptEnabled":true,"databaseEnabled":false,"takesScreenshot":true,"networkConnectionEnabled":false,"warnings":{},"desired":{"platformName":"iOS","deviceName":"iPhone 5","platformVersion":"7.1","app_path":"build/Debug-iphonesimulator/","app":"build/Debug-iphonesimulator/"},"platformName":"iOS","deviceName":"iPhone 5","platformVersion":"7.1","app_path":"build/Debug-iphonesimulator/","app":"build/Debug-iphonesimulator/"},"sessionId":"a220c01e-0a29-4e8d-bbdf-417db06ae5f0"}

The 0.24.1 version of appium_lib is super old. Please update to the new gem release (4.1.0).

If you want to see why the error is triggered on the old version, you can open up this file on your computer:

/Users/julia/.rvm/gems/ruby-2.1.2/gems/appium_lib-0.24.1/lib/appium_lib/driver.rb line 264

I recommend using a debugger such as pry-byebug. The app path logic had some bugs in the old gem which have since been corrected.

thanks!! i updated the appium_lib and it worked… i dont know why the gem was so old because I installed appium just a few months ago