Appium click in iOS Hybrid App (Cordova, Ionic) doesn't work

I just setup Appium 1.3.5 to test my hybrid ionic cordova app on my iPad Air 2 with iOS 8.1. Everything looked fine (i can get the page source by switching the context, i am able to find elements) until i try to click on an element.

I do and nothing happens. The test just continues.

Any ideas?

Hi @aluedeke,

Could you provide more details on what kind of element you are clicking and what properties does this element have? Also, is this element available under NATIVE context or WEBVIEW context?


Have the same problem as well , any idea for solution ?

Here are some details:

Looks like the chromedriver doesn’t support the latest changes to chrome. I fixed it myself in chromedriver and used this patched version. Then it worked.

Facing same issue… Did you guys find resolution for the same?
Do we need to patch chrome driver, we are trying to automate iOS app which uses safari browser. App is returning Native_App and WebView as the contexts

iOS uses safari I think…

Any updates… struggling with this…